Ugoos Cube X2 Harmony Bluetooth

I am trying to pair a Ugoos Cube X2 with a Logitech Harmony wireless keyboard. In the logitech setup I created a new entertainment device, supplier microsoft, name Kodi. The coreelec bluetooth setup page shows the wireless keyboard. When I try to pair it, it shows an error and doesn’t pair, and an error pops up. When I try to pair via the terminal (ssh) interface via bluetoothctl I get the error message: org.bluez.Error.Failed coreelec.

Can somebody please help me?


It seems there are problems with bluetooth. You need to search the forum, but the immediate answer is buy a dongle.

Thanx. I hoped that I could do it without a dongle. But if that is the most easiest way, I buy one.

I bought a bluetooth dongle (ugreen), but I am still not able to connect the Harmony keyboard. I think the onboard bluetooth chip is not disabled. As a result, the onboard bluetooth chip is used to connect the Haromny keyboard which doesn’t work. Is there a way I can force the system to use the dongle?
When I run bluetoothctl it only shows one controller, and I suspect to see two controllers.

I have same box. I can pair built-in BT with my TV. So propably Your BT chip is working well.

Thank you for this information. When I looked further I noticed that pairing is not the problem. The harmony pairs with the X2. But connecting is the problem.

I tried a lot options, but this is what happens every time:

[bluetooth]# pair 00:04:20:EF:1E:76
Attempting to pair with 00:04:20:EF:1E:76
[CHG] Device 00:04:20:EF:1E:76 Connected: yes
[CHG] Device 00:04:20:EF:1E:76 UUIDs: 00001124-0000-1000-8000-00805f9b34fb
[CHG] Device 00:04:20:EF:1E:76 UUIDs: 00001801-0000-1000-8000-00805f9b34fb
[CHG] Device 00:04:20:EF:1E:76 UUIDs: 830a5548-5c66-23bd-0949-c0040000227e
[CHG] Device 00:04:20:EF:1E:76 ServicesResolved: yes
[CHG] Device 00:04:20:EF:1E:76 Paired: yes
Pairing successful
[CHG] Device 00:04:20:EF:1E:76 ServicesResolved: no
[CHG] Device 00:04:20:EF:1E:76 Connected: no
[bluetooth]# connect 00:04:20:EF:1E:76
Attempting to connect to 00:04:20:EF:1E:76
[CHG] Device 00:04:20:EF:1E:76 Connected: yes
Failed to connect: org.bluez.Error.Failed
[CHG] Device 00:04:20:EF:1E:76 Connected: no

So it seems that it is connected for < 1 second, and then it gets disconnected. I have got no clue how to continue…

I found the solution. I had to change the user permission of the .cache, .kodi and .config

chown -R root:root /storage/.cache
chown -R root:root /storage/.config
chown -R root:root /storage/.kodi

Should have searched better in the coreelec forum :blush: