Ugoos X4 Pro uncontrollable

I just installed coreelec 19.5 rc2 for Ugoos x4 Pro, but it can’t be controlled by remote, I use original remote, G10S wireless, G20S Pro Bluetooth (use wireless). I also installed Coreelec 19.5 RC2 for H96 Max X3 but it does not need to be configured, no need remote.conf, it can still be controlled normally with G10S, G20S Pro, remote original, but if I use remote for A95X F3 I must put remote.conf in SD card and it could use normally, can anyone tell me what’s wrong and how to fix it, thanks everyone

Have you checked here?

1 Like

yes, but I cant control my box in coreelec with remote IR original of Ugoos, and G10S wireless, G20S Pro, have you got remote.conf for original remote of ugoos ? I cant find it in that link

I try to put a mouse in USB 2.0 or 3.0 but It not led light, not led optical, no power in the mouse, that reason no control for it, Will I try to reinstall ?

Solved. At first i used dtb ugoos but it didn’t work, i was frustrated so i used dtb s905x4 1gbs, now it works fine, thanks @betatester for helping me

1 Like

when i used dtb s905x4 1gbs, usb ports is powered and usb remote controlers works,but reboot, restart , sleep and wakeup not work. When i use s905x4_ugoosx4 .dtb , device boot corectly but no power on any usb ports, and only can control with bluetooth RC or hdmi-cec, original infrared RC not work,

What Android firmware do you have on this box?
May be you need to try update it.

Box is ugoos x4 Pro, android 11 with last ugoos firmware 1.1.10. On android all controls work fine but when i use iptv with native diferent streams decode bad… mpeg-ts - mpeg2, h264, interlaced. On coreelec works fine.

it perfect, not error if you use dtb s905x4 1gbps. I’ve checked, reboot, shutdown, hibernate (must use IR power button or learn button) and restart to Nand android all of ok