Vorke Z5 / Tanix 3 Mini Dual OS update LE 8.92 to 8.95.1 has ended with an error

Hello. On the Vorke Z5 device, I have the Tanix 3 Mini firmware. This is a dual system in beta version LE-TX3Max-20180125 with Android 7.1.2 and LE 8.92, ie. After uploading this version and enabling LibreElec appears on the TV screen characteristic "boxing fps" ie seconds after second the picture slows down and speeds up anyway all the time round. In the previous, stable version TX3Max-20180109 it was the same until the moment when LE replaced this system image with the version LibreELEC-S905.arm-8.2-8.2.4.tar. Then the problem disappeared. In the new LE-TX3Max-20180125 I tried to replace LE 8.92 with CoreELEC version 8.95.1 prepared by adamg88. Unfortunately to no avail. After rebooting the Tanix device, the message *** Error in mount_flash appears: mount_common: Could not mount / dev / system *** *** Starting debugging shell for boot step: mount_flash … type exit to quit *** I am asking for instructions on how to fix it. Can I upload LE / CoreElec by another method? By the way, the question: What file * .dtb matches the Amlogic S905W processor with the firmware LE-TX3Max-20180125? I am asking for your understanding, I used Google translator. I am a beginner user.

Upgrading from LE versions to CE is advised against.

The recommended method is a clean CE installation and reload settings / addons manually


You can’t upgrade the Tanix dual OS.

You have to boot CE from external and then you can proceed to install CoreELEC to the internal eMMC but it will overwrite Android and LE.

Thank you for responding to Poida and adamg. I am a beginner user and it can be difficult for me, so I am asking for tips on how to do it.
Dygresja: I tried to install the CE system on an SD card earlier, but the installation using the toothpick and the update.zip file did not give anything, the system did not move. Maybe you need to add a separate dtb file?

Of course you need a DTB file.

Thank you very much. According to the guidelines, I will try to install the 8.95.1 system on the SD card. In the case of booting from the NAND memory, it will certainly be more difficult, so I will pause until the release of the CE stable version and wait for the image of a stable system for the Tanix 3 Mini. I need experience and knowledge that I need to get. Over time, he continued to work with the theme.

Another option is to get a decent SD card, and not bother with the internal memory at all.

1 Like

Thank TheCoolest.

I have a Tanix TX3 mini, it’s neither difficult to install nor unstable.

You just need to download the S905 img.gz burn it to an microSD card and copy gxl_p281_2g.dtb to root and rename it to dtb.img.

Hold the button on the bottom of the device and insert power, job done.

Also booting from internal isn’t complicated, I think your over-analising things.

I doubt Tanix will release any more updates for the TX3 mini, that’s like trying to find the pot of gold at the end of a rainbow.

1 word of caution is that there is no WiFi driver for these boxes and there never will be.

Thank you for your interest in the subject from your side and for answering. I would like to continue the topic because it applies to all this time one device, i.e. Vorke Z5. I managed to upload CE 8.95.1 on Vorke Z5 (works with Tanix 3 mini firmware) to SD card. It’s nice to work, but not as fast as from NAND memory and it’s a shame. Appetite grows as you eat … Maybe I will receive from you tips on how to install the CE system in NAND memory so as not to spoil the device and not remove Android.
In the previous installation I downloaded pre-made files for the remote control for Vorke Z5 with LE 8.2.3 from Kszaq (digression: LE from Kszaq works great, a good piece of work). And the pilot worked very well. The CE 8.95.1 configuration is different. Does anyone have files ready for the Vorke Z5 remote and will write me how to install it.

The pilot works. It seems that the dtb I threw on the SD card was not the latest. The only question is if I can use the configuration files that worked nicely under LE. For example, the “power” button acted like a pause, the “mute” button is used to emulate the stop button and the “home” button.

No, LE 8.x uses a different remote configuration system.
@boot2k3 may know how to do something similar with the CE remote system.

Also, it’s “remote”, not “pilot”.

1 Like

You can use example (link above) to assign or re-assign button action.

1 Like

Once you are running CoreELEC from SD, SSH to your device and type installtointernal to install to internal, it’s self explanatory from that point forward.

1 Like

Thank you for the tips. I will certainly use them.

PS. TheCoolest “remote” is not “pilot” I know that :slight_smile: Excuse me . Something did not work with the translator :wink: Regards