WakeOnLan not working

installed the latest nightly today
using yatse android remote to send a WOL but it still not working
any explain how to set up the WOL properly on the odroid N2 with Coreelec ??

thanks in advance

Have you checked in CoreELEC settings under hardware if the option is enabled?

1 Like

yes was all checked but found the error the mac adress i used was not right.
now everything works fine and i dont need to pull the power supply any more everytime to Start the Odroid N2!
But thanks for the quick reply. wish all the Team the best for 2020!!! Regards

Using 20191230 nightly, wake-on-lan from poweroff works reliably, but for some reason wakeup from sleep only works once ( 1 sleep + wakeup cycle ) but doesn’t afterwards ( wakeup via cec still works, so the device isn’t wedged )

1 Like

I have the same problem…

Hi,

I’m thinking about switching my MediaCenter vom RPi4 to LePotato and CoreElec.
Wake on LAN would be a big argument to do so. Is it working again? Is it generally working on LePotato?

Thanks a lot :slight_smile:

I just tried this as would be great to power on without having to get up. Where do you enter the MAC Address??

what changed that wake on lan is so broken past 9.2.0? As mentioned with the nightly it only works once on suspend and on 9.2.1 it is not working at all.

This fixed yet?

1 Like

Not for me with the nightly_20200218 and Odroid N2

X96 Air, same issue. It worked fine not too long ago but I can’t be sure when it broke.

WOL (working only once) should be fixed with tomorrows nightly.

3 Likes

Thank you. It seems I only miss something when it’s broken.

This is excellent news if fixed, i use Kore remote to shut off the device when i go to sleep, but sometimes wake up and want to turn the tv on again, but cant be bothered to go into the other room to wake it up with the remote.

Anything special you have to do like mac codes or anything?

https://github.com/CoreELEC/linux-amlogic/commit/e1f2a8b3c871e7bb8a2ccd0ac964efd288773063

I have no idea why this code is in mainline Linux as it is not working. It was much better in 3.14 kernel.

Updated to 228. It’s working!

unfortunately WOL still not working here after suspending odroid n2, tested on 9.2.1 and also today after update to 9.2.2. no problem to wake it up with CEC remote.
when checking with ethtool, it shows wol d, then tried to change it - did so and shows wol g, but nothing changes in the behaviour.
WOL seems to be still broken…
wol d

  1. Check that wol is enabled in config.ini(or in CE settings), after go to step 2
  2. For clean experiment power off the box, unplug power cable for 10 seconds, plug it again.
  3. try to power off or suspend a box and check again.
    If nothing work then follow Portisch link to collect logs

ethtool output has nothing with WOL working state on box

2 Likes

well, i’m dummy, it was even disabled under CEC gui. thanks, you brought me to that with your hint.
it is indeed working now…

About | FAQ | Terms of Service | Privacy Policy | Legal Notice