Wetek Pro remote

I am using Coreelec on a Minix U9-H (SD) and since the minix remote doesn’t work out of the box I bought also a Wetek Pro Remote that should have worked out of the box. Unfortunately it doesn’t seem so…quite strange mhhh, what I am doing wrong and how could I fix this problem?

I don’t have a wetek, but I think you need to check you have the correct device tree. If you have you then need to read about how to create a remote.

Thanks @bubblegum57! Can you tell me which remote is supported out of the box?

Read this How to configure IR remote control

On a clean install and if you have followed install instructions correctly then the Minix remote does work out of the box, Im unsure about the WeTek pro remote but I know the standard WeTek remote most certainly works ootb.

This is quite strange since the system was installed correctly and actually works correctly except for this problem :confused: I downloaded coreelec using the download helper in the homepage and then burned on an sd and then placed in the minix and started. There is something more to do that I haven’t done yet?

EDIT: Now I’ve also swapped the dtb.img but still…should this be done before the first boot and not now? Maybe is this the root of the problem?

So you completely skipped step 3 here?

It makes no difference swapping the dtb later because without doing this step some users will find they are unable to boot and are then like :man_facepalming: when they realise that they did not follow all of the instructions.

Anyway the only reasons that the Tanix or Minix remotes would not work out of the box is if you did one of the following.

  1. Used a LibreELEC dtb
  2. Copied a remote.conf or restored one from a previous backup.

Yes, I skipped it but the U9-H has always booted correctly. Now I’ve done step 3 but even now neither the minix stock remote nor wetek pro remote are detected as well. To be more precise what works is only one or two keys.
I haven’t copied a LibreELEC dtb and I haven’t even copied any remote conf, the same goes for the backup :s

EDIT: So…do you think that if I redo everything from the ground up formatting the sd should it work correctly?

Just follow the instructions, without skipping any parts, and see for yourself. You can’t really be surprised that you experience issues, if you choose to only follow some of the necessary steps. :thinking:

Well, I’ll try again following the guide as intended. I’ll let you know about the result.

1 Like

Tried. I followed the guide: How to install CoreELEC
I have done everything that should be done before booting from the SD and nothing more but the result is the same. Now, I don’t know why, but I can assure you that no remote works out of the box on Minix U9-H with CoreElec.

Is this the RF Minix remote or this other cheapo thing?

Also I don’t see any Minix ootb remote

If thats the cheap IR minix remote. Again if that’s the RF remote they sell separately it will work ootb
No idea about Wetek Pro remote.

Yes @Ray is right Minix is not supported OOTB, it was removed in 8.95.6 as part of the unification work, sorry for my previous misleading post.

If you do the following command via SSH then the Minix remote will work.

echo "meson-ir * minix_neo" > /storage/.config/rc_maps.cfg

I have confirmed this on my own U9-H.

As for your issue with the Wetek Pro remote, I don’t have one available so I don’t know if the remote codes are the same as other Wetek remotes, if they are different then this would explain why it doesn’t work out of the box and you would need to follow the remote guide for setting it up.

On a side note, the following remote.conf may give much better responses than using meson-ir for the Tanix remote, this was pulled directly from the U9H Android image, just copy it to your sdcard and you do not need to do anything else.

Thanks, this fixed at least the Minix standard remote. What I need now is a remote supported out of the box that include a keyboard (something like the wetek pro), can you suggest some good ones?

I use the Minix A3, it’s fantastic, it requires no configuration as it’s RF based so it is seen as a keyboard/mouse by the device.

It’s also much faster and more responsive than any IR remote.

1 Like

Do you mean the Minix Neo A3, right? Thanks for this suggestion! I’ll try it asap :slight_smile:

Yes that’s the one, guarantee you won’t be disappointed with it.

I think… but don’t quote me on this, that the Minix Neo A2 Lite is the same remote just without the voice option and it’s slightly cheaper, voice is only useful if you use Android as well.

There is also the Minix Neo W2 which is the same as the A2 Lite but with a backlit keyboard.


Sorry to continue this old post, do you mean the A3 will work inmediately after installing coreelec in the U9? I am newby in this. I just bought the box with the A3 remote (I’ll get it in the next days) and I want to make sure this will work after the installation. Thanks!

I got this remote. I think most buttons work ootb. I did had some update on the keymap a while back and I think I send it to Adam too but I lost it somewhere. I need to look into it again

1 Like