❓ Which DTB do I use?

I’d like to contribute to this list, but how do I find out which dtb is in use? (I tried a few before I finally found one which worked as my box has fake ram)

SSH to your box and type cat /proc/device-tree/le-dt-id


In this post you find an extended list: https://www.kodinerds.net/index.php/Thread/62495-Welche-Device-Tree-DTB-IMG-ist-die-richtige-für-welche-Box/?postID=476160#post476160

Every time i update CoreELEC, i got this message after rebooting :

“Filesystem corruption has been detected! prevent an automatic repair attempt continuing press any key or off your system within the 120 seconds”

I always have to do this trick while booting on sd image :

Login over SSH and execute dd if=/dev/zero of=/dev/dtb bs=256k count=1 then dd if=/flash/dtb.img of=/dev/dtb bs=256k

Is there a permanent fix for my Minix U9-H?


You can just ignore this message.
Sometime in the past your volumes were not cleanly unmounted (power failure, Kodi crash, …) and a “dirty bit” was set on your file system.
Because your installation obviously works as expected, you don’t need to do anything.

It is possible to remove this dirty bit using fsck, but it’s not worth the hassle, because after the next failure, it’s back again.

My Tanix TX92 2G RAM and gigabit lan tested okay with gxm_q201_2g_1gbit

Hello Adam,

There was a list here showing working devices with CE. Do you know where is the list now?

If you read the first post, you’ll see that the list is available on CE home page under the download section.

I have an MXQ PRO 4K that uses p201 android software, but boots with gxbb_p200_1G_100M.dtb, rather than the p201suggestion

1 Like

MXQ PRO 4K is totally irrelevant as far as Brand Hardware goes.
The relevant Hardware specs to determine which dtb.img will HOPEFULLY boot your box are the soc and the ethernet speed.
You might want to disclose these details when posting.

1 Like

The page cannot be seen, click to jump to the download page。

The download page has a list of devices/DTBs. It’s a waste of team’s time to maintain two lists in two different places.

Hi. I own a XORO HST 250 S and would like to run CoreELEC on it, but my device is not listed.
Can I use the DTB for the XORO HST 260 S?
If not, could you create a DTB for the 250?
Thanks in advance

If this box doesn’t have a S905 or newer SoC, it won’t run CE.
Looking at specs, quad core ARM A5 CPU doesn’t sound like a S905 or newer. So it won’t run CE.

1 Like


I have Venz V10 Pro, it uses Amlogic SOC S905x, 2G (2G/16G internal memory), 100 Mbps ethernet. DTB that I used and that should be used for it is gxl_p212_2g.dtb.
Successfully used CoreELEC-Amlogic.arm-9.0.1-Generic.img.gz on SD card with gxl_p212_2g DTB image. After few days of testing successfully installed to internal memory on first try. So far it seems to be running solid and fast.

From Official Venz firmwares you can confirm it uses p212, 2g model so obviously gxl_p212_2g (original Android FW for unrooting and restoring to factory even contains p212 in its name).

I previously used original and official Venz FW dual boot LibreElec / Android combo but found out I almost never booted or used Android, LibreElec (8.0.2) was more responsive and overall better for my needs.
Recently found out about newer versions of LE and later of CoreElec, decided to try it out and I’m most satisfied with it.

Thanks a lot for submitting your device details.
This box is added to our download helper, now.

I’m sure, you won’t regret switching to CoreELEC. :slight_smile:


i have bought a Tanix Tx3 Mini…
i think its the 2nd edition (no clock in front) - different remote…

Selected Tanix Tx3 mini dtb
When i boot to Corelec i get no response from remote…

(my father that has the 1st edition of tx3 mini, remote works fine)

What should i do ?
thank you…

Try the default gxl_p212 DTB.

Thank you i will try and report on my findings

Isn’t the tx3 mini a S905W device if so gxl_p281_1g should be correct and you may need to create a net remote file. check NEW Repo for Remote files (Thanks to Betatester)

1 Like