❓ Which DTB do I use?

Yes windows will see it as a 512M Dos Partition. The rest of the card is used as storage for CE the first time you boot CE it will format it. It is quite common for windows to want to repair the partition its nothing to worry about.

Just copy gxbb_p200_2G_1Gbit.dtb from the device trees directory to the root and rename it to dtb.img

Did that work, if so post back it will help others using the same box.

OK, so when i power on the device whilst pressing the reset button, it takes me to a boot up screen that asks a bunch of questions.

reboot sys now takes you back to old LE and old Kodi
reboot to bootloader does nothing
apply update from EXT gives a bunch of fails
apply update from cache I didn’t try and assume does nothing
apply from ADB says waiting for adb sideload, failed does not exist

Have a quick read of this there is are apps that may help

Also a photo of the recovery screen may help to Identify the dtb you need

I have some issues with Ugoos X2 Pro :frowning: With g12a_s905x2_4g_1gbit.dtb i didn’t get USB working, even power on the ports is absent. They works normally on Android, so it’s definitely not a hardware problem. Please help.

Edit: After original firmware updating all became to normal :slight_smile: Sorry for disturbing.

Edit2: Nope, after first hardware reboot USB stop working, on Android still works normally :frowning:

Ugoos X2 Cube works fine with the same bootable SD-card (only DTB is changed to the appropriate g12a_s905x2_2g_1gbit.dtb), USB is there. Here are the dmesg logs for both X2 Cube and X2 Pro, please help to struggle this issue.
dmesg_x2_cube.log (84.6 KB) dmesg_x2_pro.log (84 KB)

Edit: Ok, just have compared unpacked original and coreelec dtbs from the both models - there is no difference that could be related to the problem. Moving to the general S905X2 thread then…

I have ugoos x2 pro Box and I have some issues.
Are there solution?
How can I use this box with CE?

Thanks for the answers!

did you got the s10 working?

I have a s10, not supported, tried many systems, many gxm-q201-3g variants, no sucess.
Once it worked on armbian boot, when to to get the device on the s10 running armbian (not sure why but cat /proc/device-tree/model says Khadas VIM2, it can be the armbian files old bug)

I tried to run a dtb files existent on the original firmware file, no luck, I tried to split it and get the dts file, the best that I coud do (no sure if I did any mistake)

until now, no success to make this boot.

DDR4 3GB eMMC 32GB S912 AC WIFI Gigabit LAN

S10 Mini Amlogic S905W 2GB RAM 16GB ROM

Please disclose your Hardware Specs.
I had to Google and found two chips.

Is not S10 mini, is just S10 (or R-TV BOX S10) sometimes the tv box as Xgody instead of S10 logo on the cover.

I decompiled the dtb coming the the firmware,

here the link

What dtb use for Mecool KM9 4GB 905X2 Box?

g12a_s905x2_4g.dtb I think.

I hope that si work with KM9. Maybe they add official support in next update for KM9, KM3 and KM9 Pro boxes?

They will give support for the processor S905X3, but not for the individual boxes itselves, I think, but It will work, sooner o later.

Hi, I bought H96 Max X2 (S905X2) 4GB/32GB.
I tried with dtb g12a_s905x2_4g.dtb
But is not working well. When I power off and I try to power on, I can’t, I need to unplug from the wall to can power on again. When It’s power on in Android, the LED is in blue color, and where the tv box is power off, the LED is in red color. When I start with CE, all the time de LED is in red color and when I go to power off, the LED is in blue color and is not possible to power on again.

I extracted the original dtb from Android and tried to copy to CE but tv box doesn’t power on:
dtb.img (256 KB)

The amlogic-dt-id [g12a_u212_4g]:
amlogic-dt-id (13 Bytes)

Hi, I have an p201 1/8gb 100M(lan) s905 mxq pro 4k (lots of different hardware on this “model”). Until recently i was running libreelec with the flowing dtb (http://kszaq.libreelec.tv/s905/8.2/device_trees/S905/gxbb_p201.dtb).
I decided to go with coreelec but now i’m having troubles with the dtb file. I’m only able to boot with gxbb_p200_1G_100M. Everything works on a fist look, but the box freezes from time to time and when i reboot it i get the message( Filesystem corruption has been detected?
To prevent an automatic repair attempt continuing ,
press any key or power off your system within the next 120 second). I suspect that this is caused by the bad dtb.img. I try different sd cards and the result is the same so. I assume a good dtb can be build easy from this two dtb files for coreelec but i don’t have the knowledge. I will be thankful if anyone can help me.

I was gifted some Micro-SD cards and USB flash drives from a family member awhile ago. Most of those that was bought off of ebay exhibits this.

However it doesn’t always means it’s the media that’s bad, could be some corruption causing yours. However for my case, using something that wasn’t bought off of ebay worked, LOL.

Whenever I have to deal with any microSD cards and/or USB storage, I always use this F3 Digirati Utility to check/test the storage against any frauds.