❓ Which DTB do I use?

Is not S10 mini, is just S10 (or R-TV BOX S10) sometimes the tv box as Xgody instead of S10 logo on the cover.

I decompiled the dtb coming the the firmware,

here the link

1 Like

What dtb use for Mecool KM9 4GB 905X2 Box?

g12a_s905x2_4g.dtb I think.

I hope that si work with KM9. Maybe they add official support in next update for KM9, KM3 and KM9 Pro boxes?

They will give support for the processor S905X3, but not for the individual boxes itselves, I think, but It will work, sooner o later.

Hi, I bought H96 Max X2 (S905X2) 4GB/32GB.
I tried with dtb g12a_s905x2_4g.dtb
But is not working well. When I power off and I try to power on, I can’t, I need to unplug from the wall to can power on again. When It’s power on in Android, the LED is in blue color, and where the tv box is power off, the LED is in red color. When I start with CE, all the time de LED is in red color and when I go to power off, the LED is in blue color and is not possible to power on again.

I extracted the original dtb from Android and tried to copy to CE but tv box doesn’t power on:
dtb.img (256 KB)

The amlogic-dt-id [g12a_u212_4g]:
amlogic-dt-id (13 Bytes)

Hi, I have an p201 1/8gb 100M(lan) s905 mxq pro 4k (lots of different hardware on this “model”). Until recently i was running libreelec with the flowing dtb (http://kszaq.libreelec.tv/s905/8.2/device_trees/S905/gxbb_p201.dtb).
I decided to go with coreelec but now i’m having troubles with the dtb file. I’m only able to boot with gxbb_p200_1G_100M. Everything works on a fist look, but the box freezes from time to time and when i reboot it i get the message( Filesystem corruption has been detected?
To prevent an automatic repair attempt continuing ,
press any key or power off your system within the next 120 second). I suspect that this is caused by the bad dtb.img. I try different sd cards and the result is the same so. I assume a good dtb can be build easy from this two dtb files for coreelec but i don’t have the knowledge. I will be thankful if anyone can help me.

I was gifted some Micro-SD cards and USB flash drives from a family member awhile ago. Most of those that was bought off of ebay exhibits this.

However it doesn’t always means it’s the media that’s bad, could be some corruption causing yours. However for my case, using something that wasn’t bought off of ebay worked, LOL.

Whenever I have to deal with any microSD cards and/or USB storage, I always use this F3 Digirati Utility to check/test the storage against any frauds.

You was right. 3x Transcend micro-SD A2 brand new and they were all bad when using on Lunux, On windows with exFat no issues. Now is running fine with the old good Mixza SD card.

1 Like

Hi adziski. Sorry to hear that it was issue with those new cards, but I’m glad It’s been figured out. Enjoy. :slight_smile:

Hello,

Which device tree can be used for Inphic Spot i7 ?

It is Amlogic s905, 1 G, 1 Gbit

I’ve been using Libreelec in a few years with Kodi 17 but now cannot find any image for Kodi 18 for this device.

Already tried from the “device tree” forlder, whenever it refers to “p200”, 1 G and 1 GBit in the file name, but without success. The USB drive is slowly blinking when starting TV box, “inphic” logo is shown on the screen, and nothing happens. Waited for about 20 minutes.

Hello All,

In reading through this particular thread and looking at the dtb images I kept seeing reference to p200, p212, etc and did not quite know which was which.

I stumbled across this list at freaktab and thought I would share it with everyone in hopes it may help others when hunting and pecking for which dtb to try.

@TheCoolest I did not see anything like this list in the forum anywhere. hope I am not stepping on toes :slight_smile:

https://coreelec.org/dtb/

@kostaman that is the list of available dtb’s yes. The list i have shared shows the ref board number and that boards specs … which would help somebody choose the correct dtb…just extra info. Like the difference between q200 and q201 is the wifi chip, both are s912,2g,1000

WiFi chip is not what identifies a board.

CoreELEC needs your hardware SOC and Ethernet Speed…
In order to identify what DTB.IMG to use.

That list could probably do with being updated?
I don’t see any S905x3 entries there for example.

T95 S1, Amlogic S905W, 2G 16G

First of all: big thanks to the coreelec-team - you made an excellent job!

Here is the configuration for my box:

CoreELEC-Amlogic.arm-9.2.1-Generic.img.gz
Device Tree: gxl_p281_2g

IR remote: T95S1:

table T95S1, type: NEC

0x140 KEY_POWER
0x155 KEY_STOP # TV Control - Power
0x159 KEY_PLAYPAUSE # TV Control - Set
0x158 KEY_INFO # TV Control - TV In
0x157 KEY_PREVIOUS # TV Control - Vol-
0x156 KEY_NEXT # TV Control - Vol+
0x143 KEY_RED
0x10f KEY_GREEN
0x110 KEY_VOLUMEDOWN
0x118 KEY_VOLUMEUP
0x111 KEY_HOME
0x119 KEY_BACK
0x116 KEY_UP
0x151 KEY_LEFT
0x113 KEY_ENTER
0x150 KEY_RIGHT
0x11a KEY_DOWN
0x14c KEY_MENU
0x100 KEY_EPG
0x14e KEY_1
0x10d KEY_2
0x10c KEY_3
0x14a KEY_4
0x109 KEY_5
0x108 KEY_6
0x146 KEY_7
0x105 KEY_8
0x104 KEY_9
0x141 KEY_REWIND
0x101 KEY_0
0x142 KEY_FASTFORWARD
Note: I wanted to have media-control buttons.
So I made new definitons for the TV Control part, mouse, mute and backspace.
The commands are listed in the order of the buttons.

VFD
I installed OpenVFD addon and spend a lot of time in trying every *.conf of the vfd-configurations-master.zip - no success.
Then I took away the addon, tried again and got the clock-signal with t95m-s905-vfd.conf.
After that I reinstalled OpenVFD addon and could add the icons and even dim.

So, after all, the result is a perfect box.

A95X Plus S905Y2 4/32gb funhouse builds working wifi/ bt with g12a_s905x2_4g_1gbit.dtb

About | FAQ | Terms of Service | Privacy Policy | Legal Notice