WiFi dongle Odroid N2+

Hi guys, I bought two WiFi modules for Odroid (5A and 5B) but I’m fairly disappointed with their performances. So, I was thinking, can you recommend a fast, dual-band, USB 3 WiFi dongle that works (possibly out-of-the-box) with CoreELEC and Odroid N2+?

I would mainly use it to move files from my main PC to an HD that is attached to the Odroid box (FTP or SMB). Alternatively, I could install some linux distro and use that, but last time I tried I couldn’t make TinyMediaPlayer run (which is the main reason why I need to move files around). In that case, I would need a fast, dual-band, USB 3 WiFi dongle that works with [linux distro here] :slight_smile:

I don’t necessarily need a specific model, just some hint on the chipsets that are supported / work but are unsupported / don’t work.


Archer T3U / T3U Plus works on my N2+

Thanks. Meanwhile, a friend lent me an USB 3.0 dongle, chipset RTL8812AU. It works out-of-the-box, and its performances are slightly better than the Odroid dongle, but it too shows as USB 2. I tried modprobe 8812au rtw_switch_usb_mode=1 but it gave me an error (no such module) and options 8812au rtw_switch_usb_mode=1, but the adapter stops working after restarting the system, so I guess I’m doing something wrong. Or maybe the dongle cannot work as USB 3.0 for some reason.

Browsing with FTP, I finally found a list of supported WiFi modules. Will start from your suggestion and see if I find the exact same adapter or a similar one, but what exactly do I do to make it show up as USB3?

Okay, got the Archer T3U Plus, created the file create the file /etc/modprobe.d/99-RTL88x2BU.conf with the following content: options 88x2bu rtw_switch_usb_mode=1 and… I now have a transfer speed of 320 Mbps! Which is the best I can do with my current setup.

Consider the case closed :wink:

I’m curious as to how you could create the file in /etc when it’s a RO filesystem?

There is also folder /storage/.config/modprobe.d which is writable.

0: doesn’t switch
1: switch from usb2.0 to usb 3.0
2: switch from usb3.0 to usb 2.0

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.