Wifi Issues Mecool M8s Pro+

Hi there.
I have a Mecool M8s Pro + running Coreelec off a MicroSD card.
Its using DLINK DWA110 USB Wifi Interface.
I constantly having issue with streaming dropping out.
Its running on a meraki MR33 AP on 802.1g WPA2-AES
Speedtest shows approx 14Mb/s download but it seems to fluctuate. My mobile on the same AP but using 5Ghz gets between 50-80Mb/s in the same area,

lsusb is as follows
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 07d1:3c07 D-Link System DWA-110 Wireless G Adapter(rev.A1) [Ralink RT2571W]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Iwconfig shows a lot of invalid Misc
eth0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:“Quake”
Mode:Managed Frequency:2.467 GHz Access Point: E0:CB:BC:34:97:5C
Bit Rate=54 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=48/70 Signal level=-62 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:270 Missed beacon:0

lo no wireless extensions.

I have tried changing channels and can get the signal level up to -50dbm but still the same result no matter which channel.
Anything you can suggest for me to try?