Would someone please remove "X96 max plus" from the supported devices list?

I purchased this one: https://www.amazon.de/gp/product/B07L66L42V/

I have “Debugging USB” in Dev enabled.

I created the SD card from CoreELEC-Amlogic-ng.arm-19.2-Matrix_rc3-Generic.img.gz

I tried sm1_s905x3_4g_1gbit and sm1_s905x3_4g .

It does not boot.

Standing by for questions and suggestions.

Try with the 2g dtb.

Nope.

Tried with and w/o *_1gbit

Ok, and when it doesn’t boot, what exactly happens?
Have you tried a different SD card? Have you tried booting from USB? If you tried all those, it’s possible that your box has a locked bootloader, in which case you will not be able to run CE on it.

Yes I have tried all of those.

I am afraid is does have such a locked bootloader, so I will send it back.

What happens: It just boots up as it would without SD or SB connected.

Buy cheap, buy twice.
Sorry, but there are a lot of issues based X96 …
Send it back to Jeff, no problem in Germany and look around to get any better box or sbc.
Have a look at pollin.de

Alright. Thanks for the help :slight_smile:

There’s been a lot of diversity in the X’s and H’s and cousins devices. There always was some but now it’s hitting record levels as the threads with booting, wifi, BT etc problems are mounting. We advise people to buy devices that are officially supported for a reason, we can reproduce possible problems and find a way to solve them. Buying this kind of generic devices will get you an unsupported device too many times.

2 Likes

Fortunately, I am lucky enough, my X96 Max+ is ok to run CoreELEC. Thanx for your effort.

I have a suggestion to CoreELEC Team:
In the support list (CoreELEC - Device Trees), the column “Device” should be split into 2 columns, “Brand” and “Model”. Some devices are sold under a brand, some are not. Add a note to remind potential users that buying devices without a brand may be risky.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice