X96 mini does not boot


I just got a new 2G/16G X96 Mini, and wanted to boot to CoreELEC from MicroSD and/or USB.

  1. I downloaded the image CoreELEC-S905.arm-8.95.2.img.gz
  2. I burnt it with Etcher to USB stick
  3. I copied the file gxl_p281_2g.dtb from the device tree to the root folder and renamed it …dtb.img

When I try to reboot the device it is stuck on the very first screen showing the X96 symbol. I have tried 2 different USB sticks and a sd card, I have tried both the toothpick method and to reboot from within Android withTerminal Emulator. Nothing gets me beyond this first screen. It boots fine into Android without USB/sc card

Am missing something?

Thanks for your help

Yes, the name of dtb image is wrong.
Should not be gxl_p281_2g.dtb.img as in your case, but only dtb.img.

I am running into a second problem.

I installed Coreelec successfully on a x96 mini 6 weeks ago. All is working fine.
I tried to duplicate the same things with a new x96 mini which I bought recently. Same model.
I downloded the recent image onto a USB stick and tried the toothpick method (like last time)

Now all what i get is this

Any idea what I am doing wrong?

THX for your help