X96 no ssh access


first of all I would like to express my appreciation to everybody who contributes to this great Project.

I am a Kodi User since ~ 10 years and now (on a real Home Theater PC). I got myself one of these tiny cheap and sweet looking Android boxes an want to see whether one of them could eventually replace my current setup.

After everything seems to work quite well, I need to SSH into my box in order to tweak some remote control setting. Unfortunately access fails for unknown reasons.

Disable SSH password is set to off.

Web interface works
Samba Works
Tcp remote control works

Any hints are appreciated.

Best Regards

My HW:

X96 S905X 2GB/16GB

Used image:


used dtb file:

gxl_p212_2g from os image

used update mode entry method: Toothpick

Welcome to CoreELEC!
You won’t regret the switch to these cheap boxes and CoreELEC, because the picture and sound quality is compareable or even better than these bulky “real” HTPCs.

To your SSH problem:
Did you try to log into the box with the following credentials?
user: root
password: coreelec

I use 2 of these boxes myself. You have the correct DTB and so, assuming that you have already checked the obvious (eg. tried with different SD/USB), your issue can only be incorrect credentials, SSH not enabled in the CE settings or your remote SSH software is not set-up correctly


Thanks for your replies, actually the problem is solved by just writing the same sdcard again with the same image and the same dtb.
Credentialy can not have been the problem, as I was not even getting to the login prompt … also my ssh client setup is out of question … as I ssh into computers at home and around the world on a daily basis …

However up to now everything works fine … now I need to migrate my media library.

Best Regards