X96 X4 - S905X4 based box - any success?

The X96 X4 S905X4-based box seems to be widely available in the UK. I’ve just bought one (4GB/64GB refurbished) - has anyone had any luck installing CoreElec on it?

If I put a CoreElec nightly in the uSD card slot on the box (with or without using the toothpick reset button in the 3.5mm AV socket), and with the various 4GB DTB files copied and renamed to dtb.img I get what looks like a frozen portion of the splash screen.

If I boot with the toothpick and no uSD card inserted I get to the standard recovery menu that I can navigate with the IR remote.

I’m happy to do what I can to assist in terms of extracting stuff from the Android install - if people can advise me how to proceed.

Are you using a SDXC (>32G) card ? My HK1 RBOX X4 can’t identify any SDXC cards and I have to use a SDHC (2G-32G) card as a boot drive. A workaround, if you don’t have a SDHC card, is to use your SDXC card with a card reader

I am using a 32GB SDHC Samsung EVO Plus uSD card. Will try a USB 3.0 flash drive just in case though.

EDIT - Using a 16GB USB 3.0 Flash drive in the USB 2.0 port I get the same result as using the SD card - and with or without the toothpick inserted I get a frozen zoomed in chunk of splash screen. Using the USB 3.0 port the drive is ignored

I’ve partially disassembled it (popped the bottom plate off and the LED ring - but can’t currently work out how to get the frosted acrylic LED diffusion plate out.

Board is labelled : X96 - BM825_141 V1.2 21272

WiFi module is labelled AM7256

@noggin, you probably have the same box as i. I have board rev. 1.3 i think.
I already extracted dtb and dmesg files in other thread:

If you not have Gb-LAN you need to choose other dtb than i.

I used the dtb named sc2_s905x4_4g_1gbit.dtb from nighly 19.5, and booted from android with already inserted SD-CARD (so you can test on android, if SD-CARD works), and rebooted in android terminal-emulator ( https://play.google.com/store/apps/details?id=jackpal.androidterm ) with command “reboot update”.
Then coreelec install onto SD-CARD should start as box reboots.

Thanks @Kill_Bill - I’ve tried that with the latest nightly and that .dtb and I just get the frozen chunk of zoomed in splash screen. Specs of the box I ordered were Gigabit Ethernet / 1000M.

I flashed the CoreELEC-Amlogic-ng.arm-19.5-Matrix_nightly_20220728-Generic.img.gz and then copied the sc2_s905x4_4g_1gbit.dtb device tree from the folder and renamed it dtb.img

Box is labelled :
Android Player
Model : x96 RAM : 4G ROM : 64G on the bottom label

Looks like this : https://androidpctv.com/x96-x4-review/

Just seen that the rc2 download page now includes S905X4 image download with dtb selection.

When I flashed that with the 4G/Gigabit option and powered up I got a different result with my video output cycling between no signal and a blue or black screen in UHD. I get the same if I boot into Android, insert the uSD card when booted and then restart from within Android. (I get the same results with a 4G/100Mbs version too)

Also trying with a 16GB uSD card (Sandisk) does the same.

My box looks like this (red RGB-LED cable, Rev. 1.3) inside, you can see at position 3:37 in this video.

On the backside resides the PHY JL2101:

How did you remove the frosted/white acrylic diffuser for the LEDs from the main case?

I can remove the base with spudgers, and the LED PCB is just held in by adhesive tape. (The thin ribbon connector on mine is white)

I can’t see how to remove the frosted diffuser to give access to the mainboard.

There should be 12 of this plastic clips all around the casing, where the red arrows point to.
You need to somehow squeeze the casing outwards, while pushing the LED diffuser upwards.

Thanks - yes - just worked out that spudger/plectrums let me do that.

Here are pix of the top and bottom of the board in mine.

Can see the UART header.

Looks like I have an empty, unpopulated space for a chip there…

I’m going to reboot into Android and check whether it’s actually 100Mbs or 1000Mbs network connectivity…

1 Like

And guess what - it’s 100Mbs…

Then it should work with the other dtb file.
Your RAM chips all have different markings, that’s funny, maybe they replaced some of them while “refurbishing”. They are all D9QBQ FBGA and Component Marking Decoder but when they are from same batch, other number should be more similar to each other, i think.
These boxes can get pretty hot, while playing 3d-games, or 4k videos, maybe too hot.
You can drill some holes in the casing where the X96 logo is for better ventilation.

Yes - today’s nightly with the non-Gigabit dtb is now booting to CoreElec. I’ve opened a dialogue with the seller to see how they approach an incorrect description…

Thanks for your help!

No problem.
Even if this box was falsely advertised with 1GbE, 100M version it is still probably the version of X96_x4 which is sold in largest numbers, because it should be around 10$ cheaper.

Yes - it was £39 in the UK. I think refurbished referred more to the fact the box had been opened and the cables weren’t tie-wrapped.

1 Like
type or paste code here

A post was merged into an existing topic: CoreELEC 19.5-Matrix_rc2 Discussion