X96Air_100 does not load from SD/flash with firmware

For a long time I have 3x X96Air (S905X3 4/64/Gigabit) c CE (nightly builds). Yesterday I received another S905X3 4/64/Gigabit. The model number is X96Air_100. This model does not load both from ready-made flash drives/SD from existing players, and new ones prepared with CE 19.2. and stable 9.2. I used several variants of dtb.img (memory 4/2, network 1000/100). During the firmware, the matter does not go further than the X96Air logo.

Did you press and hold the reset button?
Try to use “Reboot to LibreELEC” app from Android.
If you tried the above and it still doesn’t boot CE, it could mean the box has a locked bootloader, and in such a case there’s not much we can do. It’s likely that we will need UART logs.

Yes, of course. I didn’t know about Reboot to LibreELEC. I installed it, but there is no result.
I will study how to get UART logs.

Finally, the mail delivered the UART cable and I received logs for CoreELEC-Amlogic-ng. arm-9.2.7-Generic (dtb.img = sm1_s905x3_4g_1gbit.dtb)
CE927_log.txt (25.1 KB)

and CoreELEC-Amlogic-ng. arm-19.2-Matrix_nightly_20210712-Generic
(dtb. img = sm1_s905x3_4g_1gbit. dtb)
CoreELEC-Amlogic-ng.arm-19.2-Matrix_nightly_20210712-Generic_log.txt (25.1 KB)
In both cases, the loading did not go further than the X96Air logo.

The DTB is is not compatible with your device. It stops at allocate kernel memory. May you just try other dtbs first.

I went through all the dtb options for s905x3:

there is no boot. What else can I try?

Hi skleroz,

recently I got an “X96Air_V2” instead of the advertised P3 version. This model boots coreelec using the sm1_s905x3_2g.dtb. It has a manipulated Android 9 preinstalled, which claims to have 4GB of RAM and 64GB of eMMC, which is untrue.

If you dare to open the case you might check the ICs used in your model. On my “V2” there are the following ICs:

Four ICs marked D9PFK = MT41K512M4DA-125:M from Micron on each side of the pcb, which is a total of 2GBit x 8 ICs = 2GByte

THGBMHG7C1LBAIL from Toshiba / Kioxia 16 GByte, located on the rear side

RTL8189FTV from Realtek on the rear side of the pcb. This chip is very small, so I needed a magnifier to read the label. It’s a combined WLAN b/g/n 2,4GHz (40MHz 1x1 = 150Mbit/s) and LAN SDIO.

AE-SB16001 from Apps Electronic, located on the top side of the pcb, it’s 10/100 MBit/s transmitter.

I think that your “100” version an my “V2” version might be identical. If this is true, I can provide you a link to an unmanipulated stock android which works with this model and shows the correct values for DRAM and eMMC. Perhaps this Android version also includes a newer bootloader which is better comaptible with coreelec.

Hi, Nanorobot,
thank you for your desire to help. But we have different boxes. My box has 4 GB of memory, which is visible in the boot log. Unfortunately, I can’t read the marking of the memory chips. My box does not boot with sm1_s905x3_2g. dtb, as with any other dtb for s905x3. I hope that in time a solution to my problem will be found.

Is your preinstalled Android the version " X96Air_100_20201125-2051" ?

If yes, you may have a look at this post

This guy got a version with 4GB RAM, 64GB eMMC, 2,4GHz and 5GHz, BT, but only a 100MB Lan. Perhaps his findings and a comparision of the pcb can help you.

thank you for your participation. Yes, I have the same model and android version. But the download did not go due to the fact that I used an SD card.
Failed to boot from usb flash.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.