Z69 4K 3GB S905X. 4K not working?

Well as the title says, i have a Z69 4K with 3GB ram and S905X. However i cant get 4K to work. Ive followed the recomended settings, but it still dont work. Ive played arround with the CoreELEC settings aswell with no luck.

When i try to look at the whitelist it only shows up to 1080p.

What TV do you have and how is the box connected to the TV? (AVR or anything else in between?)

S905X with 3GB RAM? Interesting combination…
From the specification:
Memory and Storage Interface

  • 16/32-bit SDRAM memory interface running up to DDR2133
  • Supports up to 2GB DDR3/4, DDR3L, LPDDR2, LPDDR3 with dual ranks

The TV is a Samsung 48" 4K LED TV, i can get the serial number if you need it. But other devices run 4K without a problem on it. It dont run throug anything. Just straight into the TV.

Make sure that the HDMI input you are using is HDMI 2.0 capable, that HDMI 2.0 setting on it is enabled.

Hmm Strange, guess the company making my box found a way. When i look at system info it shows 2787MB of total ram.

Im pretty sure my TV dont support 2.0 but gonna check.

Just checked and dont seem like it have it. The model is ue48ju6575 from 2015. Strange thing is i have a little S905X HDMI stick running 4K YouTube for me. So dont see why CoreELEC shouldnt work.

If it doesn’t support HDMI 2.0, it could be why it’s not listing the 4K resolution as an option.
Can you run dispinfo in SSH and post the link?
Also, pinging @cdu13a. HDMI 1.4 spec should still be able to handle 8-bit 4K@30P and 4K@60P@4:2:0

Sure thing, here you go: http://ix.io/1Zuf

Do you see 4K resolution in Kodi Settings?
Try to clear the whitelist and see whether it’ll auto-switch into 4K then.

Whitelist is clear, and no i dont see 4K resolution in the Kodi settings. Tried to play 4K but nothig switched. Still 1080p :frowning:

In CoreELEC section of Settings, try to enable the force 8-bit option, reboot and try again.

Have now been tried. Resolution didnt change and now the colors look really dim. :thinking:

I guess we’ll need to see what cdu13a has to suggest.

So I looked at the dispinfo output and two things stand out edid_parsing failed, and the TV is only recognized as being capable of hdmi 1.4. despite also detecting a HDMI 2.0a feature(HDR).

Out of curiosity which resolutions do you see listed in kodi?

Also try a different HDMI port. Some TV’s despite being listed as hdmi 2.0, have a mix of hdmi 2.0 and 1.4 ports. Some TV’s especially earlier HDMI 2.0 also had HDMI ports set for compatibility with HDMI 1.4, and settings for port needs to be changed to enable full HDMI 2.0 capability.

Yea that seem strange.

Well, in whitelist i have:

  • 1920x1080p 60.00Hz
  • 1920x1080p 59.94Hz
  • 1280x720p 60.00Hz
  • 1280x720p 59.94Hz
  • 720x480p 59.94Hz

And in resolutions i have:

  • 1920x1080i
  • 1920x1080p
  • 1280x720p
  • 720x480p

My TV have four HDMI ports, and have tried three of them without any change. But i guess i can try the last one out. Regarding the settings for HDMI 2.0 i dont really know where it would be hidden :thinking:

According to this all of your TV’s ports are HDMI 2.0 capable. Just look in the manual for something like deep color

Very strange, think i found something. Have activated something for HDMI 1 and are going to try it out now after my box have restarted. Well this time something deffently happned. Now my TV just dont detect a signal.

No wait, my tv was just stupid and switched to another HDMI.
After changes: Edit: http://ix.io/1ZxU