19.0-Matrix Discussion

Do these playback issues only happen with “.mp4” files? Do you have any “.mkv” files to test. I had an issue with 2 particular .mp4 files, I would get a skip during playback when I upgraded to 9.2.6, 9.2.7 or CE 19. These files were perfect at 9.2.5. The skip always occurred in the same place, but it was a very rare occurrence.

There were 2 ways to fix it. The easiest was to use a free PC tool called “mkvmerge” to remux the .mp4 to an .mkv file - this only takes a few seconds per video. These mkv files playback perfectly with all releases. The second option was to make use of an “autostart.sh” file to set a particular value to 12 or 16 (your choice). The start of this thread is linked below. The second link details how remuxing from mp4 to mkv fixed it for me. Hope this helps in some way:-

check out wiki for advanced settings, you can configure to import / export watched status (and also resume points) then export your DB as separate files selecting only .nfo. kodi will then drop the nfo’s is same dir as the media it relates to. when you re-build your lib it will pick up watched / resume point status as before (and also keep the ‘added to’ date if you like to sort you movies by the date they were added…)

1 Like

if building back clean, backup nox from addons and addon_data, and also skin shortcuts from addonds and addon_data. drop them in after upgrade, then update the addons and you customization should still be there (provided you made the customization with nox gui) if you manually dropped stuff in (like i do with a custom ‘sky tv’ style pvr guide) those will be gone. if you are doing an in situ upgrade, customization made in nox gui should survive the upgrade…

1 Like

Hi everyone.

First of all, I would like to thank you for your wonderful work :slight_smile:

I have an X96 (S905X | 2 / 16GB) android box with atxexperience v4 (Android 9 PIE) firmware uploaded. Everything works OK on Android, while COREELEC does not work with 1 USB port (I need both).

I even brought an independent 5V power supply to the USB sockets and the portable drive can be heard that it works but there is no communication with it.

Is there any chance this will work? I am using device tree “gxl_p212_2g”

Regards and I am asking for help.

i think i have this also on two s905x Mini M8s, running ATVexperience4 and CE19. dont kow if issue was ther on 18, as i flashed ATVX4 specifically to stop lockups in CE19 with marshmallow undelying (which it did resolve). i use the ‘bad’ usb port to power the box from my TV, so not an issue for me. sounds like some issue with the bootloader with ATVX4 but dont know for sure. if you boot to droid does the USB port work?

Try this solution. And also read few posts above to get the picture about it.

I’m having this same problem on my N2.
I would be more than happy to help debug this, if still not solved. I’m still “combing” the thread to see if a solution has been provided

Hello, I tried one of your method to solve my problem.
I create an autostart.sh file in .config and write command into autostart.sh:
echo 16 > /sys/module/amvdec_h265/parameters/dynamic_buf_num_margin
chmod 777 autostart.sh
reboot
Unfortunatelly it’s still the same, playback is lagging, falling apart etc.
As I do not have mkv file, I gonna try remux my source video, but it will take some time. I am staying at 9.2.5 for now.
Thank you for advice.
EDIT: I tried to remux mp4 to mkv succesfully but it’s not helping.

You can update to nightly, it should be solved there.

It helped :slight_smile: Everything works great. Thank you for your help: D

1 Like

Ok. About the sttutering Problem on some videos, I switched to nightly right now, and seems that the stuttering is gone from all the local files.

However, videos from the Netflix addon still shows stuttering (Tried with series “Lupin”).

Here are my logs:

Full LOG: http://ix.io/2Tjk
CE-Debug: http://ix.io/2Tjq

Checking my Full LOG, i see these messages as well:

2021-03-18 09:58:14.994 T:4791 INFO <general>: Display resolution ADJUST : 1920x1080 @ 59.94 - Full Screen (25) (weight: -39194917628997974097920.000)

I went to see my configuration for the refresh rate, and it shows 1920x1080 @ 23.98.

Does this means i should set it up to 1920x1080 @59.94?

Sorry, didn’t see this after I posted a follow up. It is solved for local files, as you said. Trying to figure out netflix addon now

Hello, now I experienced an odd thing, it worked great on first boot. CE19_nightly_20210318
log: http://ix.io/2Tjh
ce-debug: http://ix.io/2Tji
dmesg: http://ix.io/2Tjj
But after reboot it’s same old thing
log: http:// ix.io/2Tjn

From log all refresh rates are selected correctly.
I couldn’t help with netflix as I don’t use it. But the same part should work correctly.

I managed to download the LG HDR10 jazz video from youtube and I’m having the same problems as yourself - so you are not alone :grinning:
I tried changing to mkv and increase the buffer margin to 16, but both did nothing to help. The symptom is that the picture just cuts out randomly (screen goes black) and then comes back again. I downloaded the 1080p and 4k files from YT. Both files give problems but at different times during playback.
The 1080p is H264 and the 4k is VP9. Let me do some digging this evening.

I’ve never seen this before. I have hundreds of videos and all playback great. Could be an encoding issue??

The buffer settings are for h265 not vp9. although you can look in sysfs for vp9.

It always play great for me. Here’s video playback on CE9.2.5.
https://drive.google.com/file/d/13uyP-5SCqsQuwolORFvzESj-JFnV-HkH/view?usp=drivesdk
Here’s on CE19
https://drive.google.com/file/d/13qqAOI9X7OC1wWefs-8A8D081sjKQEbU/view?usp=drivesdk
This video:

How do you get keycodes for NON-IR remotes like G10 air mouse with dongle?
Bought a new box and a G10 remote for Matrix, and can’t find a solution. :frowning:

Just did some more testing.

  1. On 9.2.5, the 4k VP9 plays back flawlessly, the 1080p H264 has the same problems as 19.0
  2. On 9.2.7, the 4k VP9 plays back flawlessly, the 1080p H264 has the same problems as 19.0

Weird. However, during playback, the amlogic info on screen (‘o’ from keyboard) shows that the videos are SDR and not HDR for all CE versions. I downloaded these videos from YT, maybe that info is stripped or something when uploading or downloading to/from YT?? Infact, using “mediainfo” tool on windows does not show any HDR metadata. Also, the H264 file’s metadata looks unusual to me.

The files I have playback a lot better than the one you uploaded onto Google drive. There are glitches, but nothing like what you are seeing. As I said, the 4k VP9 plays back perfectly on 9.2.5 and 9.2.7 Leia.

EDIT: Just saw your last post. I’ll download it and test that 1.1gb version.

I’m inclined to think the way these files are encoded is the cause of the problem. Even turning hardware decoding off and playing back using software decoding does not help in CE.

I have a local collection of 2,000 videos on my HDD and all of them were encoded using Handbrake, StaxRip or Ripbot264. These free programs use the open source x264 and x265 codecs and I have never had any issues with any of them.

.

Thanks, but as it turns out the VP9 4k file plays back fine on 9.2.5 and 9.2.7 Leia, but not perfectly on Matrix.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice