23.976 4K No Picture on 4K Projector

I’m totally stumped. I have an Epson 4040 projector, which is capable of handling 4K HDR up to 30hz. It works fine with my Apple TV displaying both 4K and 4K HDR. When I connect my Odroid N2 running fresh installs of CoreELEC, both 9.2.7 and Matrix RC2, I get no picture when playing 23.976 content. If I play 1080p with HDR, it outputs as expected. If I play 4K at 23.976hz the screen is black. If I Whitelist 4K with higher refresh rates only, then it outputs picture but the refresh is wrong at 30-50hz. I’m totally stumped. I’ve tried every combination of Whitelisting I can think, but the moment I enable 4K 23.976hz, I get a black screen…

1.- One thing is the original resolution of the multimedia source and another thing is the display resolution, and THEY DO NOT NEED TO MATCH.

2.- Your EPSON 4040 Projector has a native resolution of 1080p, this means that any other resolution that is sent to the projector will be automatically converted to 1080p.

3.- Perhaps the HDMI cables you are using are not suitable for a 4K output resolution.

With these data you shouldn’t have a problem seeing anything. Set the output of your Odroid N2 to 1920x1080p50Hz or 1920x1080p60Hz, regardless of the resolution of the media source.

Weird product:
“which accepts 4K UHD content and upscales non-4K content
What’s the benefit if there is a downscaler behind (which marketing doesn’t tell you explicit) to match native resolution? :confused:

It’s possible that your HDMI cable cannot pass the required bandwidth, and it’s also possible that the projector doesn’t like 4:4:4 chroma input with a 4K24P.
Try to enable the Force 4:2:2 chroma toggle and reboot. See if that helps.

Didn’t fix it. I gave up and bought a JVC NX7. Problem solved

( :

2 Likes

About | FAQ | Terms of Service | Privacy Policy | Legal Notice