4K - How do I know if it's on?

I have a TCL 5-series TV, and I have it set to HDMI2.0 like I see on a lot of videos for enable HD, but, they’re all meant for xbox/ps4 game consoles.

I have a few movies in 4K (Marvel movies) but how do I know it’s switching to 4K 10bit when I play them? and not staying at 1080p 8bit that Kodi displays in when the system boots up?

To check that you need to find the info on your TV what format it’s receiving.

1080p that Kodi displays when it boots is ONLY the resolution for Kodi UI, not for video playback. When video starts playing Kodi switches output resolution to the one you selected. To get more info about Video playback in Kodi, read this, specially chapters 6 and 7.

Well… set the TV to HDMI 2.0 instead of AUTO… and that worked, sorta.

After rebooting the TV and Beelink, it worked for most 4k movies, not all… which is where I’m now confused.

If I click on a movie that KODI shows as being 4k 10bit, most of them start to open, screen gives a quick flicker and the little HD logo in the upper right pops up for 3sec and goes away.

However, I have a couple of movies that are 4k 10bit, that don’t pop-up the small icon.

MediaInfo shows both at 3840x1604, around 10mbps bitrate, 10bit colour depth, etc… and I made both files using the same saved preset in Vidcoder (same as Handbrake).

Weird…

Did you set the corresponding metadata for HDR? With x265, you need to specify them in the commandline (or have Handbrake do it if it supports HDR encodes).

Going to assume no… not sure what that is.

When I do the 4k, I use the video codec listed in the drop down for “H.265 10-Bit (x265)”.

I just encoded 2 movies the same time, clicked the settings, did batch encode and encoded both of the new Spider-Man movies. When I look at the Mediainfo they’re virtually identical. I use variable bitrate and choose a quality level, but both bitrates were about 10-11mbps, both same resolution, etc… but… Homecoming switches modes, and Far from Home, doesn’t.

https://i.imgur.com/YXb0leG.png

You need to have the correct color matrix, transfer and primaries data and also the mastering metadata or it won’t work correctly.

The metadata, if any, should be in the Encoding settings part.
For example stuff like “colorprim=9 / transfer=16 / colormatrix=9”, “master-display=G(13250,34500)B(7500,3000)R(34000,16000)WP(15635,16450)L(40000000,50) / cll=4390,1327”

CLL is not always defined, some releases don’t use the value at all.

You can also see the data like this:
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : PQ
Matrix coefficients : BT.2020 non-constant
Mastering display color primaries : Display P3
Mastering display luminance : min: 0.0050 cd/m2, max: 4000 cd/m2
Maximum Content Light Level : 4390 cd/m2
Maximum Frame-Average Light Level : 1327 cd/m2

The metadata must be set in the x265 commandline, I don’t think it’s possible to add it afterwards.

I think you should compare the data of your encode and the original and see if there is a difference which would explain the other one working and the other one not.

I was in another forum as well, asking about this because wasn’t sure which forum was the right one… and someone there pointed out that one file was BT.2020 and the other BT.709.

I guess despite both being 10-bit colour, BT.2020 is the newer/better one? and that icon popping up was actually HDR which I guess is more colour than resolution related.

I did finally find a button to bring up current display information and when I switch to the 4K movies, it is indicating that I am in 4K mode now.

Annoyingly though, when that HDR pops up, it uses a different video preset which I had to go through and match to the “normal” preset that I already tweaked a bit here and there, stuff like brightness, contrast, that one option that makes everything look like it was filmed like a soap opera…

I think it’s all good now… and I guess if the source is BT.709 10Bit, it’s still good… but I can’t make it into BT.2020 so just have to live with it. :slight_smile:

About | FAQ | Terms of Service | Privacy Policy | Legal Notice