5Ghz WiFi Fails, 2.4Ghz Works(Logs Included)

I have an X3 Air Android box (Amlogic s903x) that will only connect to my 2.4Ghz and not my 5Ghz network.


Any ideas?

Any help here?

Have you looked at your router channel set for 5Ghz
Could be an overlap problem.
Not sure what country you’re in but certain routers will use the recommended channels for your country.
I had that issue with a cheap chinese box a while back.
I manually locked in a channel on my router and it fixed it.

Use an Apk named WiFi Analyzer on your phone to see what’s going on and what channels are being used

What router are you using? Does it have “Band Steering” option in WiFi section? If it does, turn that option to ON:
Band steering is a technology that detects whether or not the wireless client is dual-band capable, and if it is, it will push the client to connect to the less congested 5GHz network. It does this by actively blocking the client’s attempts to associate with the 2.4GHz network.
In order to use this feature, SSID names of 2.4GHz and 5GHz bands must be same.

Seem same issue for me.

In my case Band Steering is already disable.

You have to ENABLE “Band Steering”, as I wrote on the above post, to benefit from it.


Hello,if you talk to me, I don’t understand why I have to enable band steering when only the BB2 has problems on 5Ghz and not the others. Also because I wanted to purposely keep different names on the two frequencies because I have devices on the 5 and others on the 2.4. And anyway, I didn’t have these problems before. I don’t want to use band steering. I only would like 5Ghz to work properly as before.

  1. Does it work properly in Andoird?
  2. What Wifi chipset does your box have?


Hello, this problem accours on a S912 box Mecool BB2 . Seem do not work also in Android so may be broken.

Perhaps my experience will be useful for you. One of my old devices is an H96 Pro Plus with an S912 processor.

The WiFi adapter is dual band 2.4/5 GHz, but the 5 GHz WiFi never worked well (the HDMI output would go crazy after a few minutes, a few hours or a day or two, the processes would stop and I would lose control of the device. The 2.4 GHz connection worked well but did not offer the necessary features for IPTV considering the degree of interference from neighboring networks.

My solution was to unboot the device’s internal WiFi adapter, and install a new external 2.4/5 GHz USB WiFi adapter. Now and for many months my H96 Pro Plus works very well, and it can be working permanently without problems.

Note: To unboot the internal adapter I included the following line

blacklist wlan




Today I thought of putting an external USB net card. Are they all compatible? However this box is at least 3 years old and was fine before. Something has probably really broken. Thanks for the advice

Not all USB WiFi adapters are compatible, look in this forum and in stores for those adapters that can be used with Linux kernel 3.14 and CoreELEC. You will also have to find the name of the module (driver) that your device uses in order to disable it.

I discovered one thing, 5Ghz actually works but it’s the problem elsewhere. I state that this S912 is connected to a repeater as described in the post:

In this repeater I have activated the MAC filter so that only the MAC addresses in the list are allowed to access it. However the 912 MAC was already in the MAC whitelist so it had to access it. I discovered this by temporarily disabling the MAC filter on the repater. I added the 912 MAC again by overwriting the existing line and saving the changes. Having done this, the 912 connected to the repeater with the MAC filter active. So I suspect something that got stuck in the repeater.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.