8.90.4 Whitelist for 1920x1080 / 1280x720 at 60Hz appears broken?

I’ve got most of my Whitelist resolution issues resolved, but then last night I tried a video that is 1280x720 at 59.94 and I cannot get it to play correctly.

My Samsung KU6000 supports both 1280x720 and 1920x1080 at 60HZ and I have both enabled in Kodi.

When I play the video the audio plays but the video is completely disjointed. It looks exactly like what happens if I were to play a video at 30Hz with only 24Hz enabled.

I tried disabling 1920x1080 at 59.94 and 60Hz and leaving only the 1280x720 whitelist enabled as well as the inverse of those settings and it had no effect.

Also, when I play that video the signal coming from my Odroid to the TV is correct though. It’s shows on the Samsung TV info display as 1920x1080 or 1280x720 at 60HZ (depending on how I had my whitelist configured).

I’ve checked the video on my computer and it plays with no issues at all in MPC.


Unique ID : 299817189682515874064897906932936859046 (0xE18EB0BA75D6C50B6864D0E53D4FDDA6)
Complete name : \video\TV\Episode 136.mkv
Format : Matroska
Format version : Version 4 / Version 2
File size : 928 MiB
Duration : 28 min 44 s
Overall bit rate : 4 514 kb/s
Writing application : mkvmerge v21.0.0 (‘Tardigrades Will Inherit The Earth’) 64-bit
Writing library : libebml v1.3.5 + libmatroska v1.4.8

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings, CABAC : Yes
Format settings, RefFrames : 4 frames
Duration : 28 min 44 s
Bit rate mode : Constant
Nominal bit rate : 4 372 kb/s
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 59.940 (60000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.079
Default : Yes
Forced : No
Statistics Tags Issue : mkvmerge v21.0.0 (‘Tardigrades Will Inherit The Earth’) 64-bit 2018-07-02 03:34:45 / mkvmerge v21.0.0 (‘Tardigrades Will Inherit The Earth’) 64-bit
FromStats_BitRate : 4383222
FromStats_Duration : 00:28:44.573000000
FromStats_FrameCount : 103371
FromStats_StreamSize : 944898409

ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : A_AAC
Duration : 28 min 44 s
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Language : English
Default : Yes
Forced : No
Statistics Tags Issue : mkvmerge v21.0.0 (‘Tardigrades Will Inherit The Earth’) 64-bit 2018-07-02 03:34:45 / mkvmerge v21.0.0 (‘Tardigrades Will Inherit The Earth’) 64-bit
FromStats_BitRate : 125439
FromStats_Duration : 00:28:44.522000000
FromStats_FrameCount : 80837
FromStats_StreamSize : 27040365

ID : 3
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Language : English
Default : No
Forced : No
Statistics Tags Issue : mkvmerge v21.0.0 (‘Tardigrades Will Inherit The Earth’) 64-bit 2018-07-02 03:34:45 / mkvmerge v21.0.0 (‘Tardigrades Will Inherit The Earth’) 64-bit
FromStats_BitRate : 259
FromStats_Duration : 00:28:33.861000000
FromStats_FrameCount : 1083
FromStats_StreamSize : 55650

Can I update using the .img.gz file the same way as using the .tar update method (e.g. copy the .img.gz file to the update directory)?

Please post your topic in the correct category!

And what category would that be? I actually spent some time trying to figure out where I should post this and this forum seemed the most appropriate because I needed some support.

I’m not doing development and testing. I’m just trying to use it and I’m experiencing what appears to be a bug/issue.


this is not rocket science and it doesn’t require a great deal of time to find

I was asking a legitimate question, but I really appreciate the denigrating comment about rocket science. That’s a pretty terrible way to try and moderate a forum.

For the record, I posted in Help and Support and the layout of Discourse is not exactly intuitive about also adding sub-categories. If it’s so important why don’t you configure the forums so sub-section posting is mandatory rather than taking it out on the users?

Anyways, I would like to post a follow-up to the issue I was actually trying to draw attention to before it got derailed by forum posting etiquette. However, why don’t we just end it here and you you can just go ahead and delete this thread and I’ll look elsewhere for solutions.

Firstly your asking for help in the wrong forum, this is a Kodi related bug and would be better served on the Kodi bug tracker, it’s like asking Google to fix a problem with an app on it’s appstore.

Secondly I’m sorry if you feel offended but you are not the first to do this and I don’t know if it’s done wilfully to try and gain more attention or just ignorance for not bothering to look properly.

For the record, you did not post in Help and Support, you posted in General Discussion until I moved it.

We have tried to make the forum as user friendly as possible by adding the sub-categories as it was becoming a mess and it is a daily occurrence having to move threads to the appropriate sub-categories, so it feels like our efforts are in made in vain and it is just a waste of our time trying to keep things organised.

Keeping the forums organised is important as it would be anarchy if we didn’t with the amount of people we help on a weekly basis.

On your point of configuring posting in sub-categories as mandatory, we have already done this as you can not post in ‘Help and Support’ without picking a sub-category.

Lastly as stated earlier you are drawing attention to the wrong crowd, I don’t know if you are aware of the distinction between CoreELEC and Kodi but CoreELEC is just a minimal Linux distribution of which we package the latest version of Kodi at the time of building the images, we are aware of issues with Whitelist as there is a mountain of posts on the awful feature already, when Team Kodi fix it then it will eventually trickle it’s way into one of our releases and then on to you.

1 Like

Fair points and I appreciate the measured response. I’ll take my issue to the Kodi forum. I’m a very regular forum user and I always try to post in the correct areas, but sometimes it is just not that clear (I really thought I had posted in Help & Support). Discourse is a very different type of UX as far as ‘forums’ go so I’m not surprised if you are having issues with other users postings - frankly I’ve never been fan of Discourse’s layout.

Please feel free to remove this entire thread if it is not contributing to this forum.

I’m a fan of Raybuntu’s work which is why I moved to CoreELEC and I do intend to keep using it as my preferred distro.

If this thread remains - the issue I’m having with 60Hz videos appears to only happen on initial playing/start. If I skip ahead a few minutes everything seems to sync up (at least with the July 2 dev build I applied as per earlier in this thread). If I then skip/rewind to the very beginning of the video it is fine. If I stop and restart the vidoeo, the issue returns. I don’t have a lot of 60hz content so I can’t do more thorough testing. 30hz and 24hz dominate my content choices and they seem to work fine.