8.95.0 Kodi search option from any addon still not working

The Kodi search option from any addon still not working on 8.95.0 build. does this bug continue from Kodi developers?

Thank you

This is an intentional change in the way that Kodi handles python scripts and not a bug as such. Nothing is broken apart from incompatible addons. The change means that unless a plugin uses the new method of Caching python modules they simply will not work as before. Since it is an intentional change it will not be reverted and what will have to happen is that all the plugins will have to be ported to the new way of doing things.

There was talk of a switch to turn off this new caching feature - but it only works on a limited range of addons. There was also talk of disabling this feature by default - but the change was more fundamental than simply disabling one thing and so many addons remain broken even after disabling the python caching.

Plugins are mainly developed for stable releases and developers will be slow to port their plugins to a Kodi which might just break them again. As such we shouldn’t expect this problem to be resolved until near the final release of Leia stable.

If you have no specific reason for running alpha/beta releases of Kodi then reverting to a stable krypton or Coreelec 8.90.2 (the last version where search worked) is the best bet. The Coreelec team will not produce a patch for a functionality which is standard to Kodi Leia.

In theory this new caching feature will produce a significant performance improvement within Kodi so it should be worth it in the end. In the mean time take it up with the broken addon developers since they are the only people who can fix this.



Understood, thank you for explain, by the way, how can I access to older releases like Coreelec 8.90.2?, I saw it posted days ago but I can not find it.
Thank you

New questions should be posted separately, the old releases where removed and will not be returning, we want users to have a consistent experience and older releases contain bugs that have been fixed in newer releases.

As Leia is now in the Beta stage, the focus within the Kodi team will be on bug fixes for the final rather than major changes like the above issue, so in theory the releases should become much more stable now as time goes on.

I understood, Thank you adamg

Could there be a bit more info about what has changed,
So i can find what the problem is and see if i can fix it myself ?

Look here:wink:

I do mean with the caching that needs to be changed in the plugins.
the changelog doesnt really specify anything about that or i am missing something.

Kodi 18 has changed something in the plugin handling reason searching has been broken,
Though i have been unable to find what exactly has changed so i can find what needs to be done to fix it.

Its very unlikely that you will be able to fix this. Kodi has changed a basic functionality in a pre-release version. The simple fact is that every Addon that uses this functionality will have to migrate to the new way of doing things and it is a fundamental change which is not amenable to a quick fix.

This is what happens with pre-release software. If you can’t live with out it, go back to 8.90.2 (the last Coreelec which worked) or go back to a stable release of Libreelec, ie Krypton based.


I noticed with this build and kodi 18 beta the metahandler database is not getting initialized when performing a search. Is there a new way to initialize or is the python db connection broken? This is my experience when testing addon searches. kodi 18 alpha2 addon search works and initializes metahandler db. kodi beta 1 no db initialization with the search just ending.It seems from this code:

from sqlite3 import dbapi2 as sqlite
logFile.info(“Loading sqlite3 as DB engine”)
from pysqlite2 import dbapi2 as sqlite
logFile.info(“Loading pysqlite2 as DB engine”)

If you are facing this issue “Kodi Search Not Working” and really want to get rid of it, then simply you have to follow this link, as here you will get the exact solution for this error.


This issue was repaired long ago, no one should be running a version of CE so old that it remains broken. CE 8.95.0 is no longer supported by the team so its long past time to upgrade to 9.0.3