8.95.2 and CrazyCat-drivers


#1

hello all,

hardware: XBox-DVB-C-receiver on a odroid-c2

problem: after an update to the latest CoreELEC-version (8.95.3) my DVB-C-Receiver is ot listed any more in TVHeadend-server

downgrade back to 8.95.2 -> all is ok

Could it be, that the XBox-receiver isn’t supported anymore by the CrazyCat-driver of the latest Version? Can anybody confirm this behavior?

Kind regards


#2

I had the same problem, I had to re-select the correct driver module. I think, under all addons, there should be Libreelec modules, make sure that is installed, then choose the correct cray cat module.


#3

thanks for your answer!

i have tried your solution with 8.95.3 -> doesn’t work for me!

first: i tried it with the chorus-webinterface: deactivate-reboot-activate-reboot the driver -> no detection of the XBox-receiver in TVHeadend

second: try with direct connected keybord and display and using the driver-module-app -> same result ( no DVB-C-receiver could be find)

downgrade to 8.95.2 -> all works fine

next tests possible on next weekend -> i hope for a solution

kind regards


#4

CE 8.95.3 follows @CvH changes in LE. The latest crazycat updates dvb drivers to comply mainline kernel changes. For some drivers there aren’t patches for 3.14.29 linux and they were removed for amlogic kernel.
I’ll create “legacy crazycat” dvb driver addon (version from 8.95.2) to add ability support affected devices.


#5

What I did, was setup server, type that ip address :9981 into a web browser not Chorus, I then saw my tuner, Folder, but no contents.

I then changed the module, then went back to web page I then saw the tuner files, if the first module doesn’t work, try another module.


#6

you had use the Kodi-GUI -> same as my second try
Perhaps i maked a mistake! I will try it a second time on next weekend.

@afl1: that’s sounds great

kind regards


#7

I changed the module, in the Kodi modules addon, I then checked the webpage on my laptop, to see if the adapter file was there.

In my case, I could see the tuner folder, on the webpage, but only saw the files, after I selected the correct module


#8

Did you get the chance to make this addon? I can’t find it in the CE repository. Thanks.


#10

Hi everybody,

I’ve got the same issue with odroid-c2, Mygica T230 (August DVB-T210) DVB-USB-receiver and CE 8.95.3 ; receiver not listed in TVH-server-configuration

Choosing media_builds for the fitting modules seems to partly load the modules needed, but there is a failure message:

[ 12.811664@1] si2157: probe of 2-0060 failed with error -11
[ 12.814526@2] dvb-usb: no frontend was attached by ‘Mygica T230 DVB-T/T2/C’

DVB-receiver-model is:

Bus 001 Device 003: ID 0572:c688 Conexant Systems (Rockwell), Inc. Geniatech T230 DVB-T2 TV Stick

Trying to use 8.95.2 didn’t solve the problem. Could you fix that or give me a hint of how to make this work? That would be great.

Kind regards


#11

Hi everybody,

I solved the problem by choosing CrazyCat modules instead of media_builds.

Perhaps you might want to change the description for the CrazyCat modules as they are suitable for more than just TBS cards.

Thanks for your great work, CoreELEC is working like a charm. :smiley:

Kind regards


#12

I’ve just installed 8.95.4 and tried all 3 available DVB modules and still no sign of my Xbox dongle. The built-in K1 Pro tuner works fine.


#13

Try install this version driver.dvb.crazycat-9.0.0.zip. Pls, publish kernel debug log - dmesg | paste


#14

Thank you the adaptor is detected with that addon. I made two debug logs before and after installing:

8.95.4.1 before crazycat addon http://ix.io/1q9m
8.95.4.1 after crazycat addon http://ix.io/1q9r


#15

THX for log. I’ll push fix, in next nightly build will be included. For testing new addon version you have to manually remove zip installation.


#16

Ok, I’ve done a fresh install of last night’s build (20181027) and the Xbox adaptor is being detected BUT now the builtin tuner isn’t! :smile:

Log here http://ix.io/1qgP

Wait hang on, I think I forgot to change the dtb (it’s been a while) Nope, sorry still not working with correct dtb installed.


#17

sorry for the late reply - i was very busy with a new job!

I have tested the the new release 8.95.4.2 (directly updated from 8.95…2)

it works with three XBOX-Receiver great and immedeatly

THANKS A LOT!!!


#18

It looks like wrong dtb. You have to use gxl_p230_k1_pro.dtb.


#19

Thanks for the reply. I’ve been having a bit of a play to see if I can get it working. First of all I did a complete fresh install of the latest nightly (20181030) with correct dtb (double and triple checked!) and upon first boot and installing TVH4.2 server the availink (built-in) tuner is visible in TVH webui. If I then go into the driver module selector and choose either “DVB drivers for TBS” or “DVB drivers from the latest kernel” and reboot, the Xbox tuner becomes visible and the availink disappears. If I then switch back to “LE default drivers” neither are visible.

dmesg from right after fresh install is here - http://ix.io/1qxC
dmesg from after my fiddling is here - http://ix.io/1qxL
full kodi logs here - http://ix.io/1qxN

edit: OK I’m not sure what I did but some combination of rebooting and installing your driver.dvb.crazycat-9.0.0.zip has made them both visible. http://ix.io/1qxR

Hopefully you can make more sense of it than I can.


#20

TVH is trying cache dvb adpaters config, but this caching has bad implementation. In your second log I see both driver were loaded successfully

[ 19.652203@3] dvb-usb: found a ‘Microsoft Xbox One Digital TV Tuner’ in warm state.
[ 19.655007@3] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 19.758347@2] dvbdev: DVB: registering new adapter (Microsoft Xbox One Digital TV Tuner)
[ 19.758374@2] usb 1-1.3: media controller created
[ 19.759330@2] dvbdev: dvb_create_media_entity: media entity ‘dvb-demux’ registered.
[ 19.772298@2] 8021q: 802.1Q VLAN Support v1.8
[ 19.877424@2] i2c i2c-2: avl6862: found AVL6862 family_id=0x68624955
[ 19.877436@2] i2c i2c-2: Load avl6862 firmware patch for DVB-S/S2 size=44108
[ 19.962122@1] wifi_platform_bus_enumerate device present 1
[ 19.962134@1] ======== Card detection to detect SDIO card! ========
[ 19.962139@1] sdio_reset_comm():
[ 19.976363@0] mn88472 5-0018: Panasonic MN88472 successfully identified
[ 19.987369@0] tda18250 5-0060: NXP TDA18250BHN/M successfully identified
[ 19.989238@0] usb 1-1.3: DVB: registering adapter 1 frontend 0 (Panasonic MN88472)…
[ 19.989266@0] dvbdev: dvb_create_media_entity: media entity ‘Panasonic MN88472’ registered.
[ 19.996111@0] dvb-usb: Microsoft Xbox One Digital TV Tuner successfully initialized and connected.
[ 19.996646@0] usbcore: registered new interface driver dvb_usb_dib0700
[ 20.001079@1] sdio: queuing unknown CIS tuple 0x80 (2 bytes)
[ 20.003710@1] sdio: queuing unknown CIS tuple 0x80 (3 bytes)
[ 20.006320@1] sdio: queuing unknown CIS tuple 0x80 (3 bytes)
[ 20.010944@1] sdio: queuing unknown CIS tuple 0x80 (7 bytes)
[ 20.076336@1] mn88472 5-0018: downloading firmware from file ‘dvb-demod-mn88472-02.fw’

You can clean this cache by command:

rm /storage/.kodi/userdata/addon_data/service.tvheadend42/input/linuxdvb/adapters/*

and then restart TVH service.


#21

Thanks, I’ve had to restore an earlier backup to get everything working and am not sure when I’ll be able to get round to giving that a try. Would that be a permanent fix or is there a fault with TVH? It was all absolutely fine prior to version 8.95.3.