9.0.1 and MySQL/MariaDB


#1

Hi guys. After posting too many times in the master thread for 9.0.1, i will do it the right way and start my own thread regarding the issue I have.
I will fast forward to the core issue: After updating to 9.0.1 my advancedsettings.xml destroys CoreElec. After reboot, I have 10-15 seconds before the system freezes, and the application (not the machine) restarts. If I remove my advancedsettings.xml everything works like a charm.

It is quite strange, it is the same settings file as I have used before, not changes have been made. I was able to create a logfile, but it will show nothing of interest since the application has not been restarted or triggered to be restarted when the logfile is created. https://paste.kodi.tv/ecocipibos

My advancedsettings.xml looks like this (same file is used on a PC running libreelec, fully functional):


mysql
192.168.1.69
3306
kodidb
mypassword
videovuxen


mysql
192.168.1.69
3306
kodidb
mypassword
musikvuxen


true
true



-._ [-._ ]
@eaDir
@EADIR


@eaDir
@EADIR




-._ [-._ ]
@eaDir
@EADIR


@eaDir
@EADIR



@eaDir
@EADIR

Thanks in advance!


#2

I use CE 9.0.1 with MySQL 8.0.15
and my “advancedsettings.xml” does NOT look like this at all, but like this:

…

mysql
...
3306
xxxxxx



mysql
.
.
.

3306
xxxxxx
****

…

And this same DB server settings are working also for Win/Lin/Android.
So,
the problem seems to be at your end only, for now…


#3

I would try changing the name tag and let Kodi create new tables to see if the problem is actually with your database.


#4

Exactly.
If you use only one DB server instance, in your “advancedsettings.xml” just add the following:

<name>whateveryouwant</name>

before the <user> config line,
and check what will come out of it.
If it works fine,
your DBs are fracked up, start over filling the database(s) from scratch, for example…

P.S. Make sure you’re on MySQL greater than 5.6 and MariaDB >5.5


#5

Yeah, sure, that is a good plan! I was a bit surprised that it was the advancedsettings.xml that (probably) was the stopper, as the file worked fine in 9.0.0 and the equivalent LE distribution running on a PC. But there might something more to it, so why not trying to create a new DB by changing names on these!

And yes, the tags looked weird when pasting into the forum, so I added a screenshot for reference:


#6

Thanks for your response @ChimeyJimmey!
Just had a quick look in phpmyadmin, I am running on MariaDB 5.5.59. I hav thinking about upgrading to 10 for a while, but I will wait until this is sorted out. Thanks!


#7

Good evening!
Okay, I started from a blank page again. Clean installation, and everything was set up in the “right order”.

  1. Added Soruces (tested both smb and nfs).
  2. Scanned
  3. Played some random media
  4. Added a slimmed advancedsettings only containing basic information regarding mysql (now a non-existing database for MariaDB 10).
  5. Data synked nicely to sql, both video- and music library was created as it should.
  6. Restarted the box in order to “reproduce” the issue.
  7. Application freeze as it has done after the last upgrade. I checked the error log but since there is nothing that triggers the restart at the time when log is created.

It is very strange!

I got a tip from a friend to try a nightly, just for the sake of it. I will do that. Next test for me is to roll back (yet another clean installation) to 9.0.0, the release where it worked fine last time. Just to be able to rule releases out, or not.


#8

This may not help you, but I started from a blank database (running MariaDB 10.x on a Synology NAS) last week with CE 9.0.1, and everything went fine.


#9

Exile82: Post kodi.old.log file please.


#10

Thanks for your tip, @Fredouye! Actually, I ended up doing that as well


#11

Yes @vpeter. I will do that again. I posted a log file in the opening post though: https://paste.kodi.tv/ecocipibos

Problem is that the log doesn’t say much, since the restart isn’t triggered by the time the log is created.


#12

How about your dmesg log, maybe that will show something, kodi logs is only half the picture.


#13

Sorry for late reply, it has been hectic in my private life this week. But, I have tested a bit more, but always ending up with the same result. Freeze and restart. My “hunch” is that this issue actually is connected to mysql/mariadb and not really connected to Coreelec as such. It is still a bit confusing since it was running like the clock previously.

Anyway, the logs don’t say much: https://paste.kodi.tv/ibaviyayum.

I also created a dmesg after a restart, this log does not tell me anything, on the other hand I am totally useless in decoding this:
https://paste.kodi.tv/iqulijotav

Hope this helps you to find a clue. Anyway, I am so grateful for your support!!

Thanks!


#14

The only thing I can think it being is one of the entries in the database is causing the issue as we have many other members using MySQL with no issue.

I see your using 2 separate tables for audio and video, so you could try changing one of them to an empty table to narrow the issue further to see if my hypothesis is correct.


#15

Thanks @adamg. Yes, I Will do that. Music library is empty and not used, so I can get rid of that without a sacrifice.

Tonight I changed the setup on my PC running Libreelec, so that it would connect to the new db (mariadb 10) as the CE Minix does. I got the exact same issue on that one also. Not a CE issue then. Definitely a mysql issue.

The only thing that bothers me is that I worked flawlessly up until a week ago, then something happened that interfere with my boxes. Eventhough I created new DBs, something is fishy…


#16

Well in that case it wont make much difference if you only have a video library.

I’m convinced it’s either your configuration or something in your database that causes Kodi to lock up, have you tried Kodi on a normal desktop (not LE) with the same setup?


#17

Hi Exile82

one difference between my setup and yours : I forced MariaDB 10 on 3306 TCP port (Synology runs it by default on 3307). I did this last year, when I had issues on a Shield running Kodi 17.

If you want to try, it’s better not to modify /usr/local/mariadb10/etc/mysql/my.cnf, as it’s overwritten after each MariaDB’s package update.

You can follow this procedure : https://www.synology.com/en-global/knowledgebase/DSM/tutorial/Service_Application/Can_MariaDB_settings_be_customized_on_Synology_NAS

IMHO the only needed setting is this one :

[mysqld]
port = 3306

My setup :
Synology NAS running DSM 6.2.1-6 / MariaDB 10.3.7 on 3306 port
Shield running 7.2.3 ROM / Kodi 18.1
Beelink GT1 Ultimate running CE nightly from 03/14
Mini M8S II running CE 9.0.1


#18

Thanks everyone for your invaluable input, it is very appreciated. I have experimented further, using old/new databases, testing on both MariaDB 5 and 10, on three different platforms (CE, LE and Kodi for windows), with the same result. The outcome is restart, every single time. Even the old databases that actually worked is messed upp for some reason. I do not know if there is something in my share that does this, or if it is connected to accesses or authority. I have no clue, and to be honest I do not know where to start looking. I guess I have a couple of hours of Google sessions in fron of me.

Anyway, we can close this thread as it is in no way connected to CE!


#19

Hi @Fredouye. I am out of ideas now, so thank you for the tip.

Just a question, your recommend to not modify the my.conf file, but that is what is suggested when reading the description. How did you do? Did you create a new file?


#20

Synology recommande to create a new file : /var/packages/MariaDB/etc/my.cnf

Once created, you just have to restart MariaDB :

/usr/syno/bin/synopkg restart MariaDB

or

/usr/syno/bin/synopkg restart MariaDB10