9.0.2 Unable to install/update from CoreELEC repo

Yep, I’ve already reenabled them all, all good. Thanks a lot for your help.

1 Like

Thanks a lot for the update @teamCE!

1 Like

Is there any other option than delete Addons.db (by editing SQL inside maybe)?
The same issue (although CE repo is 9.0.2, when update CE addon it looks for 9.0.1 addon path) with install/update CE addons:

2019-05-13 21:13:12.435 T:3983532912   ERROR: Requested path https://addons.coreelec.org/9.0.1/Amlogic/arm/script.amlogic.displayinfo/script.amlogic.displayinfo-9.1.100.zip not found in known repository directories
2019-05-13 21:13:12.436 T:3983532912   ERROR: CAddonInstallJob[script.amlogic.displayinfo]: failed to resolve addon install source path

but deleting addons.db gives me to the safe boot :frowning: ( langinfo.xml is present in normal language addon path)

2019-05-13 20:58:14.902 T:4085900064   ERROR: unable to load resource://resource.language.cs_cz/langinfo.xml: Failed to open file at line 0
2019-05-13 20:58:14.902 T:4085900064   FATAL: SetLanguage: CLangInfo: failed to load resource.language.cs_cz language information

############### END LOG FILE ################

############ END kodi CRASH LOG #############

@JimmyS try changing to English GB before deleting the file.

1 Like

It works, thanks. Still wondering why this happens (both repository / language problem), and if this could be avoided in future… Will follow this procedure also for other installs.
It was 9.0.1->9.0.2 update through .tar, Confluence skin, Odroid C2.

@JimmyS when you delete the addons*.db then any downloaded addons are disabled, this includes languages and as your system is trying to use a language that is disabled that is why you got put into safe mode.

Fresh installs will not have this issue.

1 Like

Copied .tar to .update. Corrupted file error message and didn’t update. Auto reboot and then a message saying that a new update was loaded. After rebooting again 9.0.2 was installed with no errors. Nice :slight_smile:
Then, as I thought that a few addons should have been updated, I decided (my bad) to delete Addons27.db (after a backup, of course).
From then on it always crash several times and start in safe mode (marron? really? :thinking:).
Tried to delete .kodi and renamed .kodi.FAILED to .kodi (after copying there the original copy of Addons27.db).
No avail, it still crashes, restart in safe mode, and recreates .kodi.FAILED

What can I do?

EDIT: Even if I keep de safe mode and proceed with configuration it still crashes and restarts in safe mode again.

Was you using a different language?

Yes, portuguese

You should have changed to English as explained previously before deleting the file.

You need to stop Kodi with systemctl stop kodi and change locale.language in guisettings.xml to resource.language.en_gb and then start Kodi with systemctl start kodi

NOTICE to all other users, before deleting Addons27.db please ensure you change language to English GB first!

2 Likes

Tried to change that setting but it was already with language.en_gb. Anyway kodi now didn’t crash, and all my addons are enabled.
Should I delete Addons27.db now to be able to update addons?

As long as you set language to English before hand then yes you can delete it.

Is it safe to set “enabled” directly in the table Addons27.installed?

a short question. Will this break an existing installation? Do I need to manually change this on every updated box?

I use four 905X Boxes in grandmas house, and the only things changed is TVH and german language, and confluence as skin

@tavoc no, updating is fine, the above is only needed if you have issues accessing the CE add-ons repo.

1 Like

Hello, I’m not able to install any IPTV client into my Kodi - running on Coreelec 9.0.2.

“installation failed”

Thanks

Please read this topic.

Safer fix for the above identified issue, kudos to @vpeter for the tip, no need to change language or delete any files.

Paste the following commands into SSH if you have the above issue.

systemctl stop kodi
/usr/bin/sqlite3 /storage/.kodi/userdata/Database/Addons27.db "UPDATE addons SET metadata = REPLACE(metadata,'https://addons.coreelec.org/9.0/','https://addons.coreelec.org/9.1/');"
/usr/bin/sqlite3 /storage/.kodi/userdata/Database/Addons27.db "UPDATE addons SET metadata = REPLACE(metadata,'https://addons.coreelec.org/9.0.1/','https://addons.coreelec.org/9.1/');"
systemctl start kodi
2 Likes

I have the same problem, but changing the language to English and updating the Addons27.db with the above commands haven’t solved my problem.

The Kodi log says this:

2019-06-09 11:22:14.912 T:3602899824   ERROR: CCurlFile::Stat - Failed: HTTP response code said error(22) for https://addons.coreelec.org/9.1/Amlogic/arm/virtual.system-tools/virtual.system
-tools-9.1.111.zip
2019-06-09 11:22:14.913 T:3602899824   DEBUG: CurlFile::Open(0xf34eb8c8) https://addons.coreelec.org/9.1/Amlogic/arm/virtual.system-tools/virtual.system-tools-9.1.111.zip
2019-06-09 11:22:15.018 T:3936514928   ERROR: CCurlFile::Stat - Failed: HTTP response code said error(22) for https://addons.coreelec.org/9.1/Amlogic/arm/service.softcam.oscam/service.softc
am.oscam-9.1.109.zip
2019-06-09 11:22:15.019 T:3936514928   DEBUG: CurlFile::Open(0xdb34b290) https://addons.coreelec.org/9.1/Amlogic/arm/service.softcam.oscam/service.softcam.oscam-9.1.109.zip
2019-06-09 11:22:15.414 T:3602899824   ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 403
2019-06-09 11:22:15.414 T:3602899824   ERROR: CCurlFile::Open failed with code 403 for https://addons.coreelec.org/9.1/Amlogic/arm/virtual.system-tools/virtual.system-tools-9.1.111.zip:
2019-06-09 11:22:15.415 T:3602899824   ERROR: CAddonInstallJob[virtual.system-tools]: failed to download special://home/addons/packages/virtual.system-tools-9.1.111.zip
2019-06-09 11:22:15.439 T:4091461648   DEBUG: CGUIMediaWindow::GetDirectory (addons://outdated/)
2019-06-09 11:22:15.439 T:4091461648   DEBUG:   ParentPath = [addons://outdated/]
2019-06-09 11:22:15.440 T:3788268400   DEBUG: Thread waiting start, auto delete: false
2019-06-09 11:22:15.507 T:3936514928   ERROR: CCurlFile::FillBuffer - Failed: HTTP returned error 403
2019-06-09 11:22:15.508 T:3936514928   ERROR: CCurlFile::Open failed with code 403 for https://addons.coreelec.org/9.1/Amlogic/arm/service.softcam.oscam/service.softcam.oscam-9.1.109.zip:
2019-06-09 11:22:15.509 T:3936514928   ERROR: CAddonInstallJob[service.softcam.oscam]: failed to download special://home/addons/packages/service.softcam.oscam-9.1.109.zip
2019-06-09 11:22:15.527 T:3788268400   DEBUG: CAddonMgr::GetAvailableUpdates took 87 ms

Finally I downloaded the zip files manually with wget and installed these addons from zip successfully.
But do you have any idea why I got “update failed” message during update addons?

If I delete the Addons27.db file then the configuration of addons (tvheadend and oscam) will remain?

i dont think its your setup, looks like the coreelec repo has a 403 code at the moment.
i dont think it will be offline too long,