9.0.2 Unable to install/update from CoreELEC repo

#1

I also cannot install addons now either

IPTV Client
#2

@e2zippo @Adam86 please set your language to English GB and then delete /storage/.kodi/userdata/Database/Addons27.db

You will then have to re-enable your addon’s.

#3

Many thanks for the update, I’ve installed it on an X96 and an X4, all good apart from Coreelec’s addons failing to install, Kodi addons install fine.

2019-05-13 17:47:55.684 T:4094165008   ERROR: CBinaryAddonManager::GetInstalledAddonInfo: Requested addon '' unknown as binary
2019-05-13 17:48:17.023 T:3505382256   ERROR: Previous line repeats 4 times.
2019-05-13 17:48:17.023 T:3505382256   ERROR: Requested path https://addons.coreelec.org/9.0.1/Amlogic/arm/service.aml-vnc/service.aml-vnc-9.1.101.zip not found in known repository directories
2019-05-13 17:48:17.023 T:3505382256   ERROR: CAddonInstallJob[service.aml-vnc]: failed to resolve addon install source path
#4

@sergio check your addons folder, delete any repository.coreelec folder that exists, reboot, check for addon updates and finally try again.

You should be okay then.

#5

Hi Adam, I don’t have a repository.coreelec but a repository.kodinerds folder, that is also showing on CoreELEC Add-ons/Add-on repository on Kodi. Should I delete that folder instead?

EDIT: if I remember correctly I removed the repository.coreelec folder after the 9.0.1 update to solve problems with TVH.

#6

@sergio in that case just check for addon updates and you should be able to install addons then.

#7

I’ve checked for addon updates but no change.

#8

BTW the systems boot faster and feel snappier, this was a sweet update. TBH I don’t really care about installing addons at all for now :slightly_smiling_face:

#9

@sergio your device is still polling the wrong URL can I ask you to check again that you do not have a repository.coreelec folder in your addons folder.

#10

Sure Adam, here’s my addons folder.

l1:~/.kodi/addons # ls
game.controller.default          repository.kodinerds
metadata.album.universal         script.module.beautifulsoup4
metadata.artists.universal       script.module.certifi
metadata.common.fanart.tv        script.module.chardet
metadata.common.imdb.com         script.module.dateutil
metadata.common.musicbrainz.org  script.module.idna
metadata.common.theaudiodb.com   script.module.neverwise
metadata.common.themoviedb.org   script.module.requests
metadata.themoviedb.org          script.module.six
metadata.tvdb.com                script.module.urllib3
metadata.tvshows.themoviedb.org  script.module.xbmcswift2
packages                         service.rom.collection.browser
plugin.audio.radio_de            service.tvheadend42
plugin.audio.radiobrowser        skin.confluence
plugin.video.dplay               temp
plugin.video.youtube             virtual.multimedia-tools
pvr.hts
l1:~/.kodi/addons #

EDIT: that plugin.audio.radio_de addon I installed earlier today to check if Kodi repository addons were installing ok, for the rest the folder hasn’t changed since I removed repository.coreelec straight after the 9.0.1 update in February 9.0.1 Discussion

#11

@sergio did you do this?

https://discourse.coreelec.org/uploads/default/original/2X/4/46b79283d6eb192ef07723be6ec1193b88ca03de.png

#12

Yes, multiple times, I think it’s also showing on the debug logs I posted that all the repositories were updated, that was when I checked for updates via the addons page left hand side section.

#13

@sergio I’m not sure what is going on with your installation then until I’m home later and can check to see if I can reproduce it.

I have just asked one of our users on our team chat if they have any issues with the addons repository on a clean install and they said it is working okay. Since then 2 other users have also confirmed it is working.

#14

Download the .tar file for the model of your box, put in the update folder reboot box.
Maybe it’s corrupted your installation, after doing this everything should return to normal as it should everything in its proper place! @sergio

#15

No probs, I won’t need to install any addons for a while and I’m happy with 9.0.2, I only reported the problem to make you aware, 2 other people also reported it above. Also not everyone had the TVH addon problem after 9.0.1 that was fixed by removing the repository.coreelec folder.

My installation is pretty old, I don’t remember which was the first CE version I used and built up from but it’s been a long time. Maybe I need a fresh install but I’m not looking forward to reconfiguring everything from scratch (assuming a backup would recreate the problem), I’d probably rather live without new addons as I already have all I need.

#16

@sergio the last thing I could suggest is deleting addons27.db from userdata and rebooting.

1 Like
#17

Just dropping in to say I have the same result updating to .2
Starting point is 9.0.1 on which I did manually update the repo as described by @adamg
Let it auto update, did s dance of joy and came to read up here.
No coreelec add-on will install and no repository.coreelec is present.
Tried dropping the .2 tar as suggested: no go.

I’ll keep it to this state as I don’t really need anything from the repo, see if manually installing works.

#18

Just tried: dropping the addons27.db works here.

1 Like
#19

Adam that did it, CE addons are installing now, though my addons/skin etc. are gone, I’ll see if to go forward from here or go back to the original Addons27.db, everyone else be aware, make a backup copy of Addons27.db.

1 Like
#20

@sergio they are not gone, you just have to enable them again as they will have been disabled.

Glad that sorted it for you anyway.