9.0.3 Discussion

Never mind, I’ve gone back to 9.02

reinstalled 9.0.3 and iptv does not work again. Going back to 9.0.2

Try the pvr.iptvarchive, see if that works.

I have a resolution switching problem on my tanix tx92 s912.

I have gui set to 3840x2160P 60hz.

When I play a dvd rip ( 576x432 29.97hz ) it switches resolution fine, but when i press stop the tv just displays no signal, like it can’t switch back.

The only way to get the picture back is if I “blindly” press buttons to get the dvd rip playing again.
I can then press back instead of stop to take me back to the gui with the dvd rip still playing in the background.
I can then click a 4k rip which takes a few seconds to switch resolution and plays fine, and i can then press stop and it goes back to the gui no problem.

No trouble with 1080 or 4k rips just DVD rips.

When you get no signal, SSH to box and run dispinfo command. Then paste the URL here.

Thank you


the same problem

Can you also do a dispinfo when the 4K GUI does work?
And does it work if you connect the box directly to the TV?

Playing a 4k HDR movie


I don’t have a spare 4k HDMI cable atm and to get to the back of my AVR and disconnect stuff will take me all day.

If I have to I have to but I would rather not.

Can’t see anything from the dispinfo ?

Thanks again

Check in CoreELEC Settings if there’s a 422 option. Tick it, reboot, and try again.
It looks like your AVR or TV don’t like 4K signal with YUV420.

My TV is a LG OLED55B7V and AVR is a DENON x3400h both fully support 4k HDR.

There is no problem playing anything at all, the only problem is switching back from SD resolution to 4k.

Would the force 422 option not display things incorrectly ? as all my videos including the 4k HDR ones are only 420.


I have a B7 as well, and the 422 option should work just fine.
But it works fine for me at defaults, so it must be your AVR that’s causing this problem.

This worked for me a couple of versions back.

So I just tried something else.

The whitelist section was blank, I went in and selected everything on the list apart from

4096x2160p 24.00hz
4096x2160p 23.98hz
720x576p 50.00hz
720x480p 59.95hz

The same SD file i mentioned earlier played fine and when I pressed stop it went back to the gui fine aswell.

I am using PlexKodiConnect so I checked my PlexMediaServer and it said it was still direct playing (no transcoding)

I just tried something else aswel.

I put it back to normal (removed all the resolutions from the whitelist) and set the gui to 1080p 60hz.

It played the SD file fine and when I pressed stop it went back to the gui fine too.

Then just for laughs I set the gui back to 3840x2160p 60hz

The file played fine but when I pressed stop the tv loses signal.

I already told you that you need to set 422 because of your AVR.

Yes thanks for your tip, I will try that in a moment aswell.

I just don’t like the idea of forcing all my 420 content that plays perfectly fine atm to play at 422 because of a few SD dvd rips that are causing the system to not switch back to 3840x2160 when stopped.

TBH I think i would rather have my gui at 3840x2160 and those few dvd rips play back upscaled by coreelec to 1280x720 or something.

Anyway I will try what you said and see if it makes a difference and will also try directly connected to the tv.

Thanks for your help.

The framebuffer is at full HD anyway. There’s zero benefit to run GUI at 4K on the S905*/S912 devices.
The video will be upscaled to the TV resolution. IMO it’s best to have low quality content to be upscaled by the TV.