(9.2.0) No HDMI-CEC on Odroid C2

Hi Everyone,

first I want to say I love my Odroid C2 with Corelec.

Since I updated to Coreelec 9, I can’t use HDMI-CEC. At coreelec 8 I could use the remote control of my TV automatically.
Today I do a clean install on my Odroid mit Coreelec 9.2.0 and it still doesn’t work.

Do somebody know a solution or has the same problem?

I used CoreElec up to version 9.0.2 on my C2 and CEC worked out of the box. Since I changed to an Odroid N2 with CoreElec 9.2.0 just yesterday and CEC does not work so far, I read literally every thread regarding CEC on CoreElec and found that it is still a bit tricky. Sometimes it depends on the order you switch on the devices or choose sources, respectively. Sometimes it works, when the Odroid is connected directly to the TV.

Do you get any message during boot?

Thanks for your message.
No Messages for me

Cant comment 9.2, but 9.0 branch has no special CEC issues, compared with Rpi2, for me “works” as usuall (tested on 3-4 TV brands).

By works I mean its usable when connecting C2 directly to TV. With AVR in a way is way too gimmicky to troubleshoot, I am using other remote controller instead (IR).

About | FAQ | Terms of Service | Privacy Policy | Legal Notice