9.2.2 Discussion

Hi I found this in ~/.kodi/temp/kodi.log at startup, in both releases (NG and 1GEN)

2020-04-14 19:59:12.806 T:3805266816 ERROR: ## CoreELEC Addon ## updates::get_json ## ERROR: (ValueError(‘No JSON object could be decoded’,))
2020-04-14 19:59:12.809 T:3805266816 ERROR: Traceback (most recent call last):
File “/home/adamg/CoreELEC/build.CoreELEC-Amlogic-ng.arm-9.2.2/CoreELEC-settings-34e5845c9423a4e86f0edd42ab473c3aadb17561/.install_pkg/usr/share/kodi/addons/service.coreelec.settings/resources/lib/modules/updates.py”, line 476, in get_json
File “/usr/lib/python2.7/json/init.py”, line 339, in loads
File “/usr/lib/python2.7/json/decoder.py”, line 364, in decode
File “/usr/lib/python2.7/json/decoder.py”, line 382, in raw_decode
ValueError: No JSON object could be decoded

And this in 1GEN
2020-04-15 12:15:45.001 T:3855602560 ERROR: ## CoreELEC Addon ## hardware::load_values ## ERROR: (IOError(2, ‘No such file or directory’))
2020-04-15 12:15:45.002 T:3855602560 ERROR: Traceback (most recent call last):
File “/home/adamg/CoreELEC/build.CoreELEC-Amlogic.arm-9.2.2/CoreELEC-settings-34e5845c9423a4e86f0edd42ab473c3aadb17561/.install_pkg/usr/share/kodi/addons/service.coreelec
.settings/resources/lib/modules/hardware.py”, line 440, in load_values
File “/home/adamg/CoreELEC/build.CoreELEC-Amlogic.arm-9.2.2/CoreELEC-settings-34e5845c9423a4e86f0edd42ab473c3aadb17561/.install_pkg/usr/share/kodi/addons/service.coreelec
.settings/oe.py”, line 358, in get_config_ini
IOError: [Errno 2] No such file or directory: ‘/flash/config.ini’

BR N

Hi, I have a question. Since version 9.2.1 when I have video running in the background (like IPTV or other stream) and I want to run the video through some add-on (like list or stream cinema) so I turn off the background video and TV BOX freezes, just spinning wheel ( wait). Only a restart will help.

If my background stream is off, everything goes OK. Everything up to CE version 9.2.0. The problem occurred in version 9.2.1 and now persists in version 9.2.2. This is a problem on various TV boxes, all Mecool. And it’s both on the ARM S905X and the ARM S912. I have tried everything I can. Can anyone advise?

After that freeze, sound and image are in sync?

Hi, i have a VIM3L and try to edit the keytable. But ir-keytable failed

CoreELEC:~ # ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t
/sys/class/rc/: No such file or directory
No devices found

The Khadas remote is working.
Any ideas?

Same issue on a Beelink GT1 Ultimate (S912).

Hi!
I have an Amlogic 912S box. Minix U9-H and Tanix TX9s.
Corelec 9.2.2. The new CoreElec menu -> Hardware
Each switch is not saved by CE. If CE is restarted, everything will remain off! CPU governor also remains blank.

Just wanted to chime in! Updated my Minix U9-H from 9.2.1 and it worked great, no issues so far, thanks!

Yes, sound and image are in sync after the freeze. If you like me to test something let me know.

I am experiencing exactly the same behaviour. Had to go back to 9.2.0.

Was it the aircrack-ng repo you guys were taking a look at by any chance?

@Justice yes it was.

Congratulations on the release of 9.2.2.
This actually triggered me to order an N2.
Receiving it tomorrow.
Updated a number of generic amlogic boxes and it all looks and works great. Cant wait to test the -ng line :wink:

Hello, i have a khadas vim3l and since from the 9.2.0 until this latest release 9.2.2 release i have some video artifact when i play h265 movie

picard12, upload some sample of such video.

Also congratualtions on release 9.2.2.

Works almost flawless on the Ugoos X2 Cube. Only some particular videos show stuttering and tearing, but most of them are shown properly. I am trying to figure out the details (codec, timeframes etc.) of these videos

Keep up the good work!

CE 9.2.2
Ugoos X2 Cube (S905X2)
Hi, here my logs and kodi config:
http://ix.io/2ig2
and dsmeg | paste:
http://ix.io/2ig3

Whats the issues"

  1. As CEC is working well (using TV remote) there are some minor issues.
    1a. Cannot wake up box using CEC (TV remote).
    I can wakeup just using stock IR remote. Not working WOL, CEC and of course RF (is not supported)
    1b. Have to do hard restart (unplug). After restarting CEC stopped working.
    Need to do shutdown and then start and CEC is working again.

  2. Have eth wired and WiFi 5 GHz. After booting only wired is connected. WiFi idles.
    I need to manualy “Connect”. There is no auto connecting while eth is on.

Thank You for Your work and still CE is great. :slight_smile:
I wish You all immunity.

  1. CoreELEC BL301 Wake-Up feature [inject_bl301]

I had it done already. In my case its default ON. Propably i had this as ON in nightly 9.2.1.
I checked it with inject_bl301:

Update of BL301.bin on eMMC is not needed, exit now…

I believe this expected behaviour. eth will generally be better so it defaults to it. If its not what you want then disconnect the eth cable.

Shoog

Why you disabled stream path change as CEC option in CE hardware settings? Enable all options and try again. The resulting value in config.ini have to be cec_func_config='7f'
Right now u have 6f

About | FAQ | Terms of Service | Privacy Policy | Legal Notice