9.2.3 Discussion

Sure: https://github.com/CoreELEC/CoreELEC/releases/download/9.2.3/CoreELEC-Amlogic-ng.arm-9.2.3.tar

Put this in update folder and reboot to update. Or just

cd /storage/.update/
wget -c https://github.com/CoreELEC/CoreELEC/releases/download/9.2.3/CoreELEC-Amlogic-ng.arm-9.2.3.tar

Perfect, that fixed it. Thanks guys. Very simple fix :slight_smile:

1 Like

Simple but hard to get there. Thanks for your patience!

Probleme bei A95Max beim shutdown
Box restart beim shutdown
Update am 11.06.2020 9.2.3
wieder zurück zu 9.2.2 keine Probleme

I’ve noticed you’ve had this problem for quite some time

I presume it hasn’t worked since 11th March.

I’ve been testing 9.2.3 and note that the AV Receiver restarting issue reported on the link below has not been patched in 9.2.3.

AVR keeps turning on after turning off TV (when Apple TV 4k is connected)

nein das war n anderes Problem beim Shutdown geht die Led vom Lan Display nicht aus
bei 9.2.3 bootet die Box neu beim shutdown

Please try to write in English.
Don’t let everyone else use Google translator to follow you.

1 Like

I have an A95X Max (S905X2) box which has been happily running v9.2.2 from a MicroSD card.

I’ve just updated to v9.2.3 and can confirm that the playback of local media seems at least as good as before but when I now try to shutdown it interprets this as reboot not shutdown. I’ve checked the Setting which determines the shutdown action to take and it still sys shutdown. I normally use the Transparency skin so I reverted back to CoreELEC’s default Estuary skin but this makes not differnce to this behaviour, it still reboots when commanded to shutdown.
This never happened with v9.2.2 on this box.


It works again! Thank you very much!


Thanks, I’ll work that into the next version of the how-to.

All seems fine on my Magicsee N5. I was hoping this version would fix the bug in file playback. I find if you pause a file for more than a minute it stutters when you un-pause it, also the lip sync goes out. I find if you skip back once it cures it.

hallo i have a A95 Max update to 9.2.3 and can confirm Problem it still reboot when commanded to shutdown

VC1 codec playback seems to be not fixed in 9.2.3 with HW GPU acceleration on Odroid-N2. I see now that in guisettings.xml it is explicitly disabled:
setting id=“videoplayer.usevaapivc1”>false</setting
setting id=“videoplayer.usevdpauvc1”>false</setting

I tried to place the same lines in advancedsettings.xml on 9.2.2 to do the same, but still on both versions VC1 playback is stuttered. The only way to play it smooth is to completely disable HW acceleration for all formats.

Does someone else have the same problem on Odroid-N2?

We don’t know about this issue… please upload a sample

I have uploaded a sample of VC-1 video with some dynamic scene. You can try to play it with and without HW acceleration to see the difference.


I don’t see any difference between hardware decoding on and off when played on the N2. Nor do I see any problems with any of my other vc1 encoded content.

Also the settings you referenced above are for use on a pc. Both are todo with an nvidia api and have nothing to do with playback of vc1 encoded content on an amlogic based device.

To try and narrow down the cause, if you have a spare sd card you can try a fresh install, and see if the problem still happens.

Ok thank you for checking. Then it is something with my particular installation / settings. I will try then a fresh install with default settings.

So I tried a fresh 9.2.3 installation with default settings and VC-1 plays smooth :slight_smile: Then I went one by one through all video settings and found one which causes stuttering - whitelist for display mode. For me it was set according to my TV to one value only 3840x2160 60Hz. I remember selecting explicitly this in whitelist on some rather earlier coreelec version, because I had display flickering without it while playing some 4K videos. Now I cleared whitelist and all is fine.
So can you give a short description of this whitelist setting? Surprisingly it affected only VC-1.

Some time ago the behaviour of whitelist was changed. Initially whitelist replaced the previous default autodetect behaviour and if a whitelist was not set many video issues resulted.
This was changed in CE such that if the whitelist was not setup then autodetect of HDMI settings was enabled as default (which was the behaviour before whitelisting was introduced).