CEC with CoreELEC 9.2.2 breaks ARC?

CEC doesn’t work at all on my C9. Tried with N2 and VIM, both work on other LG tv.

1 Like

Can CEC be disabled? Any thoughts as to why the menu settings don’t stick? Since I’m not using CEC to control the N2 and it’s breaking ARC for other devices I’d prefer to just disable it.

You can disable CEC from the Input menu under System settings.

@Pelican sometimes a bad HDMI cable prevent CEC from working.
Also make sure you don’t have 2 CoreELEC devices connected at the same time, I recently found out that it completely breaks CEC.

This has been happening intermittently to me since 9.2.1. In the beginning, 9.2.2 seemed to have solved this, but recently it actually became worse.
I don’t really know if the problem lies with CE though, since around that upgrade to 9.2.1, both my AVR (Pioneer VSX 1131), and my TV (Vizio 2016 P series), got firmware updates.

I am also having weird CEC behavior. My setup is like this:

ODROID-N2 - Marantz SR5010 - Samsung

When i turn my tv off. The tv and receiver is shutdown but the tv is turned on again over CEC by CE 9.2.2 ng. Also when I turn off CEC function in the CoreELEC menu and leave the menu and go back it’s turned on again.

9.2.2 4GB N2

I’ve seen similar issues with an N2 -> Denon X3600H -> Sony KD55AG8. I have disabled the CEC functions on the N2 as I was finding that when the systems were powered off by the TV AND the active source was NOT the N2 everything would power back on after a few seconds. If the N2 was the selected output on the AVR when turning off this did not happen.

Earlier this week I noticed that I could no longer change volume via the TV and that ARC was not working. Using apps on the TV - youtube, iPlayer, Netflix etc, did not send any sound to the AVR. The CEC/HMDI diagnostics on the TV reported no attached devices where it had previously seen the AVR, N2, Bluray and cable TV box (UK Virgin Media/TiVo). Having ruled out automatic firmware upgrades and cable problems it finally occurred to me to power off the N2 (it is left on). As soon as I did this the TV displayed an “Audio System activated” message and ARC functionality started working as before.

That’s exactly what I’m seeing, and it also started this week, despite the fact that I upgraded to 9.2.2 a few weeks ago (and as mentioned, in the beginning it was actually performing better than 9.2.1)

CEC on 9.2.0 works best for me

I think I got the HDMI CEC suspend/ARC issues sorted out and wanted to share my solution here, both to confirm that it’s a good solve and to make it available for others.

Part 1. Disable HDMI CEC on CoreELEC.

  1. Disabled HDMI CEC completed in System-Input-Peripherals-CEC Adapater

  2. Disabled all CEC settings in Corelec-Hardware-CEC. All remain disabled after backing out of the menu except for “CEC Wake-up” which reverts to odd. Not sure what that’s about.

  3. Using the method provided here for editing the config.ini file, I removed the comment for HDMI CEC and set it to “0”

  4. Now the various HDMI/ARC issues went away Smile ARC is reliably available and HDMI routing issues are gone.

Part 2: Use Harmony Hub to make the Odroid suspend when not in use.

  1. I added the Odroid N2 as a device in my Harmony Hub setup.

  2. I added the Odroid N2 to the Harmony remote activity for CoreELEC.

  3. I configured the Harmony remote activity to send the Odroid N2 an on/off signal during activity start/stop.

  4. Back in the CE menus, I configred System-Power Saving I changed “shutdown function” to “suspend.” Now IR power toggle puts the Odroid N2 into suspend instead of off - much faster Smile

  5. I also configured a button on my Harmony remote to fire the IR power toggle command, just in case I need to manually power it on.

Thoughts on this fix? Have I done anything that would contradict best practice? Is using the IR power toggle this way harmful to the device? I vaguely remember reading that the IR power toggle in CE doesn’t always trigger an orderly shutdown or suspend.

1 Like

@grizzledoldman can you write what exactly you do in step 3. I opened boot.ini but I don’t know what to do next. show how you boot.ini looks afer editing.

When u edit boot.ini it maybe will not boot anymore.
Point 3 is same as point 2 as CE Settings set the config.ini value already.

I mean config.ini. My mistake.

For beginners with editing files, see here (step 1& 2): How to Remote Control Configuration for Dummies Using Windows and SSH

after that:
Edit config.ini

The easiest way is to insert your eMMC/SD card to a PC and edit the values remotewakeup , decode_type and remotewakeupmask in the config.ini file by a unix compatible file editor.

The second way is to update via SSH.

Make /flash writable:

mount -o rw,remount /flash

Then edit the config.ini with your preferred editor like vi or nano:

nano /flash/config.ini

After saving type:

sync && reboot

(from the grizzledoldman 3th step link)

And the editing is at the begining of the file, delete the # before the hdmi_cec line to active the parameters

# HDMI CEC Control, 0=disable/1=enable

Short update - I’ve disabled CEC via the config.ini as above but have still seen the CEC blocking issue described in my earlier post which seems to prevent ARC from working until the N2 is restarted.

I think the reason I’ve started seeing that is that I initially disabled CEC only via Kodi to prevent with powering back on problem unless the N2 was the active input on my AVR. This meant the N2 was on all the time and that appears to trigger the other issue.

I’m going to try and create a cron job to reboot the N2 in the early hours each day to see if that helps.

This looks like a related issue where a bug has been identified and fixed - from a comment in the 9.2.3 release thread:

This is once again happening frequently, and I’m seeing something new - when this happens, I used to restart to fix. Now when I restart I get a black screen.

And since 20200706 it’s possible to choose libCEC version for testing.
Default is libCEC 4.0.4.
By touch /storage/.config/libcec-4.0.5.conf after a reboot libCEC 4.0.5 will be used.
When removing the touched file again 4.0.4 will be used.

EDIT: since 20200715 there will be libCEC 4.0.7 available to by touch /storage/.config/libcec-4.0.7.conf

Thanks. I’m using 9.2.3, not a nightly. Which libCEC version is it using?

libCEC 4.0.4

1 Like

I made the libcec-4.0.7.conf in the .config directory, but when I go to the settings menu I still see version 4.0.4.
I’ve CoreELEC version 9.2.5 and have the file libcec.so.4.0.7 in /usr/lib/

Edit: Nevermind, already seen your request at libcec, I should take a look at the kodi log.