9.2.5 Discussion

Anybody have the same issue?

System stucks when a video started on top of a playing iptv stream via Yatse(same with Kodi remote).
Steps to reproduce:

  1. Play an iptv stream via IPTV Simple
  2. Send any type of online HD video via Yatse

System will stuck at buffering logo and become unresponsive.

It started way back from 9.2.1. Same for Nightlies. NG builds work fine.

My device is Tanix TX5 Pro

Logs attached, please help.
kodi.old.log.zip (1.7 MB)

Have anyone got option to install interface languge other than English? Is this function broken?

Hello.Does Netflix 1080p run ok on X88 king?I ordered this box and is arriving in few days,so i would like to know,so to format my microSD running coreelec on my Vorke Z6 (can’t handle all 1080p streams) to install coreelec on it yo my new upcoming X88.Thanks.

Yes. My X88 King works fine with Netflix at 1080p. I bought it specifically for that purpose. My old Scishion V88 Pro (S905X) could only manage 720p on netflix.

1 Like

Very nice thanks! i hope i made a good choice!

Are HDR10+ and HLG not supported anymore? My TV doesn’t recognise it anymore and shows HDR10 (PQ), but it worked with previous CE Versions. I tested HDR10+ and HLG content.

“dispinfo” output here: http://ix.io/2HYz
(after I used echo 1 > /sys/module/am_vecm/parameters/force_pure_hlg ) suggested here: [SOLVED] HLG HDR output flagged as HDR10 PQ
“dispinfo” before that: http://ix.io/2HYx

Test sample included this file from " BBC Seven Worlds One Planet in HLG": [SOLVED] HLG HDR output flagged as HDR10 PQ

I’m still having problems with playing the next title off my NAS after I’ve already watched a movie, listened to a song etc.

I get this stuff in the normal Kodi log. Which items should be checked in the debug log to find out what is causing it? It is very, very irritating because I know that the NAS itself works fine. Switching to NFS shares didn’t help either. The only way to make it work is a reboot.

2020-12-25 01:18:05.534 T:4063665600 NOTICE: VideoPlayer::OpenFile: smb://192.168.0.75/Movies/Spaceballs (1987)/Spaceballs (1987).mkv
2020-12-25 01:18:05.535 T:2953347968 NOTICE: Creating InputStream
2020-12-25 01:18:05.558 T:2953347968 ERROR: Open - Unhandled exception
2020-12-25 01:18:05.559 T:2953347968 ERROR: Open - Error opening smb://192.168.0.75/Movies/Spaceballs (1987)/Spaceballs (1987).mkv
2020-12-25 01:18:05.560 T:2953347968 ERROR: CVideoPlayer::OpenInputStream - error opening [smb://192.168.0.75/Movies/Spaceballs (1987)/Spaceballs (1987).mkv]
2020-12-25 01:18:05.560 T:2953347968 NOTICE: CVideoPlayer::OnExit()
2020-12-25 01:18:05.725 T:4063665600 NOTICE: CVideoPlayer::CloseFile()
2020-12-25 01:18:05.725 T:4063665600 NOTICE: VideoPlayer: waiting for threads to exit
2020-12-25 01:18:05.725 T:4063665600 NOTICE: VideoPlayer: finished waiting

2 days ago, I updated my Ugoos AM6 to firmware version 0.3.9 and ran the recovery procedure to be able to boot into CoreElec on my SD card. It seems to work normally except for one major issue. I recently added several new albums to my music drive. All have been scanned to the library and both display and play perfectly in Android however, in CoreElec the album names are there but all folders show as empty.

I tried rescanning the music drive in CoreElec but it refuses to do so. In Android however, all media info has been located and displays in Kodi as it should, and that includes the files themselves which are equally playable.

CoreElec claims to be able to scan movie files but no data is ever displayed although the movies are found in their folders and are playable. CoreElec is updating its addons correctly and shows both time and weather info so it is not a case of having no internet connection.

I will admit that I have always had trouble scanning files within CoreElec but not being able to even see the files is a new issue.

Given that all the scanned data was successfully downloaded within Android, I exported the lot. Would it be possible to import those files within CoreElec and if so, how would I go about locating where they have been exported to?

Sounds like a permissions problem. Could be permissions on your CE drive or on your data drives. Check if you can write to the OS drive since it sounds to me like your CE drive has been mounted read only.

Shoog

I’m not sure what you meant by that Shoog?

I have several HDD’s connected to a USB 3.0 hub which in turn is connected to one of the USB 3.0 ports (OTG) on the AM6. The hub is self-powered. If this was a permissions issue, how is it possible that there is no problem writing to the same drives when I’m booted into Android?

The music drive is a 512 Gb USB key which is connected to the other USB 3.0 port of the AM6. Scanning to that within Android is not a problem. It only happens when booted into CoreElec.

I do not run a dual-boot system. I have CoreElec installed on a 32 Gb SD card so that when it is plugged into the AM6 it automatically boots into CoreElec.

Linux permissions are specific to Linux.
However what I said was the most probable reason this has happened is that your CE OS disk has been mounted read only and this is preventing Kodi from creating and saving your databases. You can eliminate this as an issue if you try writing a file to your running CE OS SD card, if it fails to write then this is your issue.

Shoog

So, if I’ve understood you correctly, it is the SD card that needs its write permissions changed. If that is the case, how is it I was able to write CoreElec to it? Also, I ran a backup to the card itself from within CoreElec. Surely that shouldn’t have been possible?

If I take the SD card and connect it to my Windows PC, can I check/alter the permissions within that environment?

The process of taking out the SD card and modifying it in any way can flag up to Linux that the SD card is corrupt which then forces it to become read only. It often happens even after a dd disk copy of a backup which is bit perfect.
However there is no point in speculating until you have tested it as a working hypothesis. Do the write operation to the SD card whilst the OS is running and see what happens.

Shoog

What kind of write operation can I attempt, please?
I already ran a backup and my addons all successfully update automatically so, unless the data for all of these is being written to the AM6’s internal memory rather than the SD card, I would have thought the card has the required permissions.

The .update folder should be exposed as a smb share on the SD card, Use your PC’s file manager to drop any file into that folder and see if it actually appears in that folder. This is such a simple operation which should be a standard part of your fault finding process anyway.

Shoog

Ok, I will give that a go this afternoon and get back to you.

Right, well that was a total disaster but I think it may be getting us closer to the source of the issue.

Here’s a screenshot of 3 different views of the SD card’s content according to Windows:

The first is of the root. Note, there are no .update or .smb folders. device_trees and LOST.DIR are both empty. Top right is the contents of the Android folder. Each one if its subfolders have a sub-directory called ‘files’ and they are all empty. Finally, on the lower right I opened the empty ‘files’ folder under videolan and pasted a file ‘friller.mp4’

Next, I returned to the home cinema and ran CoreElec again. Nothing we can see in the windows screenshot can be seen in CoreElec’s file manager without digging very deep and even then, the friller.mp4 file remains invisible.

So, I’m guessing that either Windows is unable to view the contents of Linux, OR all the directories with storage and databases shown in CoreElec are actually stored on the AM6’s internal memory rather than on the card itself.

You are correct - windows doesn’t recognize linux file systems so looking at the SD card directly will show nothing. However the boot partition is formated in vfat so will show the full contents of the boot disk. The STORAGE disk is where all your user files are stored such as your databases and this is in ext4 which is a Linux files system which makes it invisible to Windows.

Be warned that simply doing anything with Windows file manager and a Linux file system can corrupt it.

However SMB should be able to access those shared folders such as .update., and Coreelec shares a range of SMB folders by default. I have not used Windows Explorer for system admin for years so am not certain what Windows file manager will do when shown a Linux file via SMB.

Shoog

What is SMB?

SMB is Samba, the Windows file sharing protocol.

I think you have a corrupted SD card or at least a corrupted file system, there should be clear instructions on how to use Windows to prepare a working CE install on SD - have you followed these exactly ?

Shoog