9.2.7 Discussion

I can see your point of view and I agree. I did update from 9.2.7 to the latest 19, hoping to fix it, but it didn’t work. I could have tried the nightly. However, I have been surprised by new bugs a few times now, resulting in a planned evening of watching a movie being canceled and me having to open up my case, flash eMMC, do config backups/restore, config file edits using SSH to make my remote work, etc. At this point I just want a stable Kodi player, nothing more, and 9.2.6 is that for me.

Now that it is outside of the case still, I could try the latest 9.2 nightly build. I will and let you know if it solves the issue.

I’m using CSL HDMI cables, which work fine for even my PS5, pushing 4K 60hz 4:4:4 over them.

Why not just boot from USB stick? This way you can help resolving issues easily. After testing remove the stick and boot from eMMC.

You are surprised by new bugs a few times now and this is exactly what is wrong: how do you expect bugs to be solved? Just wait and check from time to time if is resolved or what?

I have reported some issues I’ve had, so I don’t expect things to fix themselves. The USB option is a good one.

I just got the same issue on 9.2.6 even, so I’m starting to think it’s hardware related now. The 20210402 nightly has the issue too. A complete fresh 9.2.6. as well. What I am experiencing:

  • When in Kodi menu, or during playback of any video, from USB or network, at some point TV goes black, loses signal, and the red LED stops, just the blue one stays on, flashing
  • It can hang at the CoreELEC boot screen (with the CoreELEC logo)
  • It can display the CoreELEC boot screen and Kodi wrongly; looks kind of interlaced

My TV is an LG 55C9.

Here’s a dmesg | paste from a black screen during Kodi menu: http://ix.io/2VBA
kodi.log: kodi.log - Pastebin.com
kodi.old.log: kodi.old.log - Pastebin.com

Another one: http://ix.io/2VCg

Fresh install of CoreELEC-Amlogic-ng.arm-19.1-Matrix_rc1-Odroid_N2.img: http://ix.io/2VCw, kodi.log: kodi.log - Pastebin.com

Fresh install running on a microSD; same issue.

hdmitx: system: plugout in all cases
For me it looks like cable or cable connection issue.

But also I see usb 1-1.4: USB disconnect, device number 3 the same time
Do you have original power supply? You could also try different power supply…

1 Like

This is a very good point because sometimes original power supply are really bad and cause frustrating freeze or hang like that

On N2, the red LED is hardwired to 5V supply. So if it goes off, it’s a HW failure/overload on 5V supply, or the Wall Adapter is broken/wrong.

1 Like

Luckily I have an abundance of 12V/2A power supplies. I just did a test and with another one and… I have the same. Played a file and after a while the red LED goes off and screen goes blank. I can still SSH to the N2. So… it looks like my N2 has a hardware issue?

Looks like yes, some power issue.
You could also try to unplug all usb devices and test without them.

Just tried a different wall outlet, different power supply, different HDMI cable and my PC monitor instead of TV and no USB devices. Still the same, red PWR LED and display go down.

I guess… I’ll have to find a new Kodi device. It was a good year. Thanks for your support.

/edit: or attempt this fix: fixed blown 5v regulator on my Odriod N2 - ODROID

It looks like the following commit, broke the ability to edit and save network settings.

showButton() takes a string id as the second parameter, and uses it to get a localised string to set the save and cancel button labels, but when called in connman the localised string is used instead, resulting in the following errors:

2021-04-15 12:59:20.460 T:3322454912 WARNING: ## CoreELEC Addon ## oeWindows.mainWindow::showButton(1, save_network) ## ERROR: (TypeError('an integer is required',))
2021-04-15 12:59:20.471 T:3322454912 WARNING: ## CoreELEC Addon ## oeWindows.mainWindow::showButton(2, cancel) ## ERROR: (TypeError('an integer is required',))
1 Like

I think you’re right. The parameter need to be a number as it get translated later to string:

Thank you for your support!

:+1:
Thanks should go to you and the team for all the hard work you put in.

Thanks for the hint with English UI.
Same here with Wetek Play 2 - Bluetooth dissapeared on 9.2.7. I guess I’ll wait for 9.2.8.

I’ve had a portable drive connected to my S905X3 box for a while formatted to NTFS without any issues. Recently formatted it to EXT4 for Docker but now the device won’t boot with it connected. I can unplug so it continues. Afterwards once CE is up it’ll work fine. I’ve tried different USB ports but can’t fix it. Any solution?

Sounds as if your EXT4 file system might have a dirty filesystem tag, try running fsck on the drive and see if it throws up any errors and clears them.

Shoog

1 Like

Ext2Fsd was showing it as EXT3, so something wasn’t right. I formatted again with another software and it seems to have fixed it. Thanks.

Edit: I followed this guide so it could be done within CE

About | FAQ | Terms of Service | Privacy Policy | Legal Notice