A95X-B7N booting from internal and SD doesn't work

Hi all,

I have a Nexbox A95X-B7N, Amlogic S905X, 2GB RAM with CoreELEC installed to internal. I have been using this device for quite some time, first with LibreELEC and now CoreELEC for a year and a half, without any problems. But since last week the device won’t start. I get to see the Nexbox logo, and sometimes the CoreELEC logo for one second. And then the image goes black and it looks like the device turns off (but the blue LED light stays on). I then tried different monitors and cables, but that did not solve the problem. I try to find out the IP address of the device via the terminal, but the device is not in the network. So I can’t access the device via SSH either.

Then I tried to put a new build on an SD card with the correct device tree, put the SD card in the device and then hold down the reset button with a toothpick and plugged in the power cable. I get to see the Nexbox logo, but then I get a black screen again. I have tried the latest stable and nightly versions, but both have black screens. I then tried some older builds such as 9.2.7 and 9.2.6. That got me a bit further. After the Nexbox logo I saw the CoreELEC logo. Then I saw the message ‘Partition resizing in progress’, and then ‘Rebooting in … seconds’. After rebooting I saw the CoreELEC logo for a second, and then black screen again. I still can’t access the device via SSH.

I feel like I’ve tried everything, but nothing works. It’s also so strange because before it just worked for a year and a half without any problems. Is my device just broken or is there something else I could try?

Best regards

Remove the # from this line in config.ini (root of the SD Card) and see if the issue persists:

# VOUT mode
#   You can use this setting to set a specific video mode at boot.

Works on Nexbox A95X-B7N 1/8
Log: http://ix.io/4iwf


9.2.8 Leia (Legacy) works to: http://ix.io/4iwl

Did some more testing on Nexbox A95X-B7N and I am unable to replicate your problem.

If your problem persists, I am suspecting a hardware issue.

Try with a new, stronger power supply.

1 Like

If power supply substitution does not work then maybe emmc corruption on booting sector? I saw similar reports on other forums.

How to flash firmware

First off, thanks for all the quick responses and help!

I tried this yesterday on my monitor, but it didn’t work. Just to be sure, I also tried on the television today, but that didn’t work either.

Unfortunately, same problem.

I can try this, but at the moment I don’t have another adapter in my house that fits and is stronger.

I wouldn’t know exactly what this means, but I’m going to read several pages and topics about this.

Unfortunately I don’t have a Windows operating system to try this. I’ll see if there’s another way.

Otherwise I think I’ll just have to buy a new device.


This worked! Tried the (same) adapter from a friend, and the device started up without any problems!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.