A95X MAXII almost working?

Hi everyone,

Could someone give a pointer here, please.

I’ve just got this box and followed the info to get CoreElec working.
Got it about 95% of the way but I’m stuck on a couple of things…

I’ve tried a number of the files in device tree and a number will boot the box but none will get the display working (I’m not bothered too much about this as I sit too far from the box to be able to read the display. It’s only a problem if it’s effecting the other thing I can’t work out).

The box won’t switch off. The display constantly reads ‘boot’ and the attached HD’s won’t spin down?

Can anyone suggest what I need to do?

I have looked through the forum for a fix, I may have missed it? If it’s there a link would be all I need…


Search the forum how to configure VFD and how to configure HDD´s

I have the original A95X Max an have it working well and although yours is an S905X3, whilst mine is S905X2 I do know about the box not switching off…

To cut a long story short, once upon a time the DTB for the box worked fine but following an update, every time that I tried to shut down the box it just rebooted.

Investigation showed that there was something like a 1 byte difference between the old and new DTB but other than that, nobody could see any difference.

But when I extracted the old DTB from an image and replaced the new one, shutdown worked correctly.

So every time that there is an update I just replace the new DTB with my older working one.

Now my DTB is not going to be of any direct use to you because of the differing SOC’s but based on the fact that the boxes are from the same generic manufacturer line does make co-incidence less likely.

One for the devs, although worth noting that because this is a new box there may not be a specific DTB or it at all yet as nobody may have asked for one.

As for the VFD, there is a thread here.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.