A95X -R1 / S905W issue

Can you look at the CPU on the motherboard and see what it says on it because there is 2 revisions of this device and I fear you may have bought the Rockchip version instead of the Amlogic version.

Even worse it will more than likely be a RK3229.
Current LE testing is being done on RK3328 and RK3288 with no testing on the low spec RK3229 .
Send it back or refund.

thanks for your answer, but under Android, it says Amlogic / Cortex A53 with CpuZ (vs Coretx A7 for RK3229), and the specs seems to match.

and you are right, It seems there 2 variants of the A95X R1 : s905W / rk3229

I think I tried the “gxl_p212_1g.dtb”, but I’ll try again to be sure.

I’ll try the refund if I really can’t install any ELEC on it.

Have a look at the firmware version in System Android.
See what firmware the box reads.
The name of the firmware might help.

Here are intel I gathered :


EDIT: 1 more with the back

Can you please disclose in detail.
Brand of sd card and full specs.
This may be your issue.
Edit: Use Amlogic Burning Tool and if the box is recognised you will know it’s an Amlogic Chip

I’m afraid this is what happens when you buy the cheapest device available on gearbest rather than one that is known to work and supported, I hope this will be a lesson to others.

Can you provide a copy of the original DTB from Android as well?

1 Like

There are actually 3 when i googled. There is an s905x as well.
This box is a nightmare under that name.
Freaktab have posts with this All sorts Mixed Chips Model.

SD Card : Samsung 16GB, verified after wirting / ok, working on many other S805/S905 devices.

Amlogic Burning Tool : Connect succes !

For the DTB, I don’t remember how to do that without the stock ROM in img file, but I’ll search :wink:

EDIT : I searched, but I didn’t find anything good. I have network adb with root access working. any idea/help ?

ok, with ADB, I copie boot.img with
dd if=/dev/block/boot of=/sdcard/boot.img

but the split with a 0 byte for ‘second’ (which should contain the dtb if I am right) :
./split_bootimg.pl /storage_main/tmp/boot.img
Page size: 2048 (0x00000800)
Kernel size: 7110087 (0x006c7dc7)
Ramdisk size: 1315813 (0x001413e5)
Second size: 0 (0x00000000)
Board name:
Command line: buildvariant=userdebug
Writing boot.img-kernel … complete.
Writing boot.img-ramdisk.gz … complete.

stuck …

EDIT 2 : pastebin of dmesg

EDIT 3 :
damned ! I finally managed to extract the dts file !
I found the infos here :

it’s a multi DTB.

here is the start :
model = “Amlogic”;
compatible = “amlogic, Gxbb”;
amlogic-dt-id = “gxl_p212_1g”;
interrupt-parent = <0x1>;

p212 … lol.

still not booting with the extracted DTB !!!
here is everything I extracted :

tried gxl_p212_1g.dtb : NOK :frowning:

I managed to flash the MMC with TX3 mini dualboot.
It works ! I can boot on LE

I tried many other firmware, none accept to boost on SD.
I tried sandisk and samsung sdcard. Same result.
I tried USB flash drive. Same result (stuck at boot or bootloop).

The main issue now.
Libreelec version doesn’t work very well (frame drops).
I updated it to CE 8.90.2.
It works much better … but I don’t have the remote anymore :frowning:

I tried to update the remote.conf.
no working.

I tried changin the DTB to :

  • gxl_p212_1g.dtb => boot, no remote
  • gxl_p281_1g.dtb => boot, no remote
  • gxl_p281_1g_a95xr2.dtb => boot, no remote
  • original TX3 mini (which worked with previous LE) => boot, no remote

I used this process to update to CE :

EDIT : oh yes.
I can see key logs in dmesg :

[ 473.777725@0] remote: Wrong custom code is 0xf10e4040
[ 474.040207@0] remote: Wrong custom code is 0xf10e4040
[ 474.355932@0] remote: Wrong custom code is 0xf10e4040

the /storage/.config/remote.conf

factory_code = 0x40400001
work_mode = 0
repeat_enable = 1
repeat_delay = 130
repeat_peroid = 120
release_delay = 20
debug_enable = 1

Glad you got the box to boot. But please read/search before making posts… This is not new information.

I also did that (search and copy keymaps.rc and co) :stuck_out_tongue:

$ ir-keytable -t
No devices found

The meson drivers seems to load as a keyboard or something like that.
dmesg :

[ 0.000000@0] linux,meson-fb: 0x000000003d100000 - 0x000000003f100000 (32 MiB)
[ 0.008244@0] meson_bc_timer: mclk->mux_reg =ffffff800000c990,mclk->reg =ffffff800000e994
[ 0.315256@0] vout_serve: meson_vout_probe OK
[ 0.370180@1] meson-rng c8834000.rng: hwrng registered
[ 0.390071@1] meson_uart c81004c0.serial: ==uart0 reg addr = ffffff80000fc4c0
[ 0.390113@1] c81004c0.serial: ttyS0 at MMIO 0xc81004c0 (irq = 225, base_baud = 1500000) is a meson_uart
[ 0.390139@1] meson_uart c81004c0.serial: ttyS0 use xtal(8M) 24000000 change 0 to 115200
[ 2.083129@0] meson_uart c11084c0.serial: ==uart1 reg addr = ffffff80000fe4c0
[ 2.089781@0] c11084c0.serial: ttyS1 at MMIO 0xc11084c0 (irq = 58, base_baud = 1500000) is a meson_uart
[ 2.431860@1] meson-fb has 1 memory regions
[ 2.431910@1] meson-fb meson-fb.16: assigned reserved memory node linux,meson-fb ok
[ 3.708118@3] input: aml_keypad as /devices/meson-remote.11/input/input0
[ 4.957442@0] cpufreq-scpi cpufreq-meson.7: enter cpufreq
[ 4.961753@0] cpufreq-scpi cpufreq-meson.7: probe cpufreq okay
[ 4.968352@0] gxbb_pm: enter meson_pm_probe!
[ 4.971820@0] gxbb_pm: meson_pm_probe done
[ 6.026677@1] meson_uart c81004c0.serial: ttyS0 use xtal(8M) 24000000 change 115200 to 115200
[ 6.076684@2] meson_uart c81004c0.serial: ttyS0 use xtal(8M) 24000000 change 115200 to 115200

thanks for your help :stuck_out_tongue:

one thing I really don’t undersant :
the remote.conf isn’t used anymore ?

why those “remote: Wrong custom code is 0xf10e4040” if the remote.conf is correct ?

remote.conf isn’t used anymore.

ah ok !!!
now, it’s clear :stuck_out_tongue:

any idea how to fix my issue ?

I used this :

tried X92 keyboard (since my remote seems to be detected as a keyboard …)

I also injected the empty “98-eventlircd.rules” to “/storage/.config/udev.rules.d/”

@Koxx reading your posts is extremely frustrating.

Firstly had you taken the time to read How to configure IR remote control then you would see that remote configuration for the A95X box is built into our builds and no extra configuration is needed.

You would have also seen that remote.conf is no longer used since LE 8.2.

Secondly had you copied the correct DTB as per the first paragraph in ❓ Which DTB do I use? then you would not have had the following error, nor would you be having the problems you are having now.

The A95X-R1 is an S905W device so you should be using gxl_p281_1g.dtb

Please take just a few minutes to read before posting next time, no further assistance will be provided :stuck_out_tongue:

If you flashed TANIX TX3 MAX please be precise. That firmware is a HACKED dual boot with a HACKED LE .
Flash the proper Tanix TX3 Mini. No the remote won’t work. You can work on that after. That dual boot Tanix Firmware is crap.