Addon game.libretro.vice -> run/stop


#1

Hi,

not sure whether this is the right place to ask this question, however I will give it a try:

I am using the game.libretro.vice addon to emulate my favorate c-64 games. Everything works fine so far. However I am struggeling at one point: Some games require the c-64 key “run/stop” to be pressed.

Normally (on stand alone retroarch windows installation) this key is mapped to the “up arrow” key of the PC keyboard, this however seems not to work on coreelec.

The same may apply to libreelec, but there I have not tested yet.

I supect some shadowing of the “up arrow” key to some game controller function … but I might be totally wrong here.

My Setup:
X96 (amlogic S905x 2G RAM 16G ROM) + [CoreELEC 8.95.2]

Any hints apreciated.

Best Regards
Stephan


#2

Update:

I see the same issue on a LibreELEC-Generic.x86_64-8.90.005

will report to Libreelec Forum and see whether I find a solution there … will keep you updated.

Best Regards
Stephan


#3

libretro cores use a wrapper that defines the controls on kodi. So this might just be a buttonmap issue with https://github.com/kodi-game/game.libretro.vice

Will take a look, however need an example as to which games require the c-64 key.

edit:

It might also be a matter of different settings (controller type?) being used for the libretro core on kodi vs retroarch. So probably worth comparing the core settings between the two.


#4

Under [Game Menu > Settings > Advanced Settings] try switching controller type to joystick.
(You can switch controller type back and forth between joystick and keyboard without exiting a game if need be.)

Then when you need to get past an intro screen in a game press X on your controller. (or whichever button you have mapped as X(it’s the square on sony controllers)) The vice core’s virtual keyboard comes up, but isn’t very functional without a mouse but that doesn’t matter since we are now past the intro screen and can just hit X again to hide the virtual keyboard.

This got me past the intro screen on multiple games that I tried.

While not a complete solution, it hopefully can get you playing your games.


#5

Hi, thanks for looking into that. This is a viable solution for me.

Best Regards
Stephan


#6

I just discovered that you don’t need a mouse to use the virtual keyboard. You just have to press select to enable the curser, then the left right up down buttons on the gamepad can be used to move the cursor to the key you want. The B button (or which ever button you have configured as fire) can be used to select the key you want pressed.