AML-VNC shows the wrong hostname in VNC client


When I’m connected to my machine with VNC, the AML-VNC server shows the wrong hostname in VNC client. However I’ve changed the hostname of the machine, there must be a parameter on the vnc server side but I can’t find it.
Do you have an idea?

Thank you,

I think the name is hardcoded here

which means currently it is not possible to set the name without sources change.

Thank you for your reply.

This is probably it.

Are there really no other solutions ?

Let me add proper solution later today. Which CE image you are using so I can give you addon for test?

I tried modifying the file with HEX editor, which worked fine.
I use version 20.1.
Yes, It’s possible to test it.

Hello, have you had time to work on a proper solution?

Actually I already did push all the changes: aml-vnc: add option to set desktop name (hostname by default) · CoreELEC/aml-vnc@e18f13e · GitHub

But you didn’t wrote if you use NG or NE version so I can make you addon.

Oh yes, I missed it. I use NG version.

I think this should work

If not I will try to rebuild correct version.

Thank you very much it’s work, you are the best !

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.