Android Rom for Mini M8S II and Coreelec 19.2?

Hi,
I`m still using my “old” Mini M8S II to run OpenElec but the newest version keeps causing issues. Someone one here suggested that to run Coreelec 19.2+ you need to have at least Android 7, 9 would be even better. So I have been looking around and found Aidan´s Android 9 ([v8] Aidan's ROM [S905X] [Android TV 9] [Netflix TV] [Disney+] [Google Play Certified] [ROOT] | XDA Forums). Installing and running this rom was no problem but I can´t boot into CoreElec using the toothpick method which always worked before. So I wanted to ask if anyone on here can recommend an android rom for my box that works fine with the newest coreelec?

Thanks a whole lot

I use the same box and I’ve faced the same issue of Aidan’s Android TV 9 ROM. Unfortunately, this ROM doesn’t have Root, thus we can’t use “Reboot to LibreELEC” app or reboot update command.
I see two ways how to solve the issue - rooting the box or shorting some contacts on the PCB. I haven’t tried none of them yet.
I’m pretty optimistic because of success with the other box Mecool M8S Pro PLUS. It fixed buggy vendor’s bootloader so I’m happy with CoreELEC 19.2 on this box. It changed IR code for ‘power on’, but it’s not a problem for me. I used “shorting contacts” method (on this board it’s simple and safe).

I’ve tried Aidan’s Android TV 7 on Mini M8S II. The toothpick method works, but standby mode doesn’t work, so it’s not the option for me.

I just tried ATV 4 again and this time it seems to work like a charm so far. I´ll keep testing but it looks promising.

1 Like

My ROM can be rooted using magisk :slight_smile:

I’ve already rooted the box using your tutorial, but reboot update command doesn’t boot CoreELEC.
I’ve tried to short contacs on PCB (tried different options). It didn’t help either

About | FAQ | Terms of Service | Privacy Policy | Legal Notice