Anybody having problems with Netflix?

Hey guys,

So, I’ve been getting this annoying error (addon Signals call timed out) on Netflix, which makes impossible to use the addon.

Already tried everything to fix it, including doing a hard reset to make sure there wasn’t any other addon causing conflicts, with no success.

Anybody else having Netflix issues?

To make thing worse, I’ve been trying to upload my logfile but I’m also getting an error from the logfile uploader tool (unable to retrieve url).

I’m using the latest Netflix addon on the lasted CoreELEC. Odroid C2.

By the way, I’ve also tried getting some help on the official Kodi forum thread, unsuccessfully.



Which version of CE are you using, latest stable or latest nightly?
Which version of NF addon are you using, cause there are 2 of them?
Which version of “inputstream.adaptive” are you using?

Edit: just tried NF addon v.0.14.6 with inputstream.adaptive v. and Netflix works OK on my N2.

Hey Sholander,

I’m on CoreELEC 9.0.3 (stable), Netflix 14.6 and Inputstream as well.

There are a few threads out there about people having the same issue, but no one seems to figure out what’s going on.

Somebody said to turn on “IPC over HTTP” on the expert options of the Netflix addon, but for me it only made things worse and the app stops working entirely.

I’m not an expert for NF addon, so can’t help you with this problem…
Do you have “script.module.addon.signals” installed in Kodi addon folder? I think that inputstream.adaptive should install this addon…

Do you get “Netflix - Background service started” without error after you boot CE?
Do you use default Estuary skin?

I’d try a fresh CE install, (not “hard reset”) with only NF addon installed to see if it works then…

Working normally here too. NF addon sometimes gives many headaches. So what Sholander said to see if you have some configuration problem or so.

I too have this HTTPError message in last couple of days. Not only on CE, but on Shield as well.
I guess netflix change something on their part and plugin need to be updated :frowning:

NF addon works OK at the moment. When there is a general problem to be addressed there is always a flood of posts on addon forum

The Neflix add-on is working well for me on 9.0.3 with my N2. I do have one small, but annoying complaint. I don’t use my TV box every day and when I’m not using it I do a full shutdown. The add-on tends to forget my login between shutdowns and it’s kind of a pain to re-enter that with the on-screen keyboard and remote. Though at some point I may add a TVH server in which case the box will be on all the time making the issue moot.

I switch off my box every night before i go to sleep, and turn it on next day after about 14 hours. It never forgets my login during that period. Also when I went for 3 weeks holiday and after I returned, turned N2 on and NF addon logged on automatically. I have Enabled Auto Login to my profile in NF addon settings, and this works fine for me.
Though, I do have some similar problem with “HBO Go EU” addon, which sometimes forgets my logging :slight_smile:

Is Netflix addon working at the moment?

What region are you, wonder if that makes any difference. Mine doesn’t always forget, but it does at times. Initially I didn’t have the profile set up to auto login, but then I figured it out. Thought it fixed the problem, but it still happens once in a while.

Otherwise It should be working, of course you don’t get everything in high def, but I get a good amount of 1080p content (don’t have 4k TV yet). From what I understand that’s a Netflix DRM thing that doesn’t always allow high def for some clients and some content. Not sure if that will ever change.

Yes it is…

Southern Europe (Croatia), and have local NF site to which I login to make any necessary changes. When I check the connection with my NF LGTV app it always connects to 3 NF servers…

Are you shutting down to suspend or doing full shutdown? I’m doing a full shutdown, but was wondering if shutting down to suspend might resolve the issue. Interestingly, if I simply reboot, Netflix logs in again no problem. Only forgets when the box is off for a day or so. I’m in USA, Pacific Coast BTW.

Shutting down full, even flip the power switch (I have a power switch before N2 power adapter so it’s completely out of power). Don’t use Suspend mode because my Oled display does not wake up after sleep…

For me, returning the requests to version 2.12.4 solved the problem.

From which version, that did not work for you did, you go back?
My NF (v.0.14.6) works OK with “script.module.requests.2.22.0”

On Windows 10 with kodi 19 alfa and NF 0.14.6. There is no problem on N2 with CE.