Aspect ratio issue with amcodec on some h265

Hello there !

I post today to explain you a issue that make me crazy …

I have a beelink GT1 ultimate (s912 + 3g DDR4) who run smoothly with openelec 9.2.1 .

I have some 1080p movie encoded in h265 with handbrake with a 2.40:1 aspect ratio and kodi open this in 2.39:1 resulting in a black bar under my movie …

the only thing who fix this problem is to disable HW acceleration amcodec in settings .
But without HW acceleration my box can’t play h265 movies smoothly .

More strange : I have doesn’t have problems with size 1920x800 , only with 1920x816 and 1920x804 !

After some search i find this explaination who can match with my issue : Amlogic S905X2

But the 4.9 kernel release for my CPU is unavailable and my metadata seems good …

Someone have a solution or a idea ?

PS : thanks to the team for all of your work , you make this project awesome !

I’ve forgot the log …

Every Widescreen video other than 1:1.78 have black bars on top and bottom, how is it different with 1920x816 (1:2.35) and 1920x804 (1:2.388)?

Black bars will be present on everything that is not 1280x720, 1920x1080 etc (i.e AR of 1.78) - unless you ‘stretch’ the video in the video settings. E.G. for old 4:3 movies I do use the stretch option to remove the vertical black bars from the side.

Are you saying that 1920x804 and 1920x816 don’t play at all?

I don’t talk about regular black bars !
I will take you a picture of my issue

This issue is linked to the amcodec , when I disable it , the black bar under the video disappear

no one ?
I will take any idea …
it’s probably my fault but i don’t know where the trouble is …
The same movie play perfect on kodi with android TV (mediacodec)

The height has to be divisible by 8.

Thanks for your answer !
but it seems i have issue on some 1920x1080 to … the black bar is very small so i didn’t notice it before … 1080 is divisible by 8 so i don’t know where the issue is
it seems to be totally arbitrary …