Audio dropouts every 4 minutes in MP4 playback

Hi!
I noticed a strange behaviour while playing mp4 files form a local NAS (gigabit) to my
Odroid N2 4G with CoreElec 9.2.1 on an LD 4K TV. CoreElec resolution is set to 4K, too.

Playback of 720p files ripped from YouTube is pretty good.
But after exactly 4 minutes of playtime, audio (via HDMI) is muted for about 2 seconds.
Four minutes later again and at 12 minutes again and so on.
Skipping backwards after one of these dropouts and playing the same scene again, audio
plays pretty fine and drops out again 4 minutes later.
I already played with the buffer settings and the buffering is now 50MB or so. But the audio problem persists.
Looking at the kodi logfile I found nothing suspicious.
Find attached an example part of the logfile.
Any ideas?
Thank’s!
Lothar

2020-02-28 06:22:55.104 T:4066762768 NOTICE: VideoPlayer::OpenFile: smb://192.168.229.73/multimedia/YOUTUBE/This_old_Tony/082_DIY Touch Probe & Cheap Mist Coolant.mp4
2020-02-28 06:22:55.105 T:3911971712 NOTICE: Creating InputStream
2020-02-28 06:22:55.279 T:3911971712 NOTICE: Creating Demuxer
2020-02-28 06:22:55.326 T:3911971712 NOTICE: Opening stream: 0 source: 256
2020-02-28 06:22:55.327 T:3911971712 NOTICE: CVideoPlayerVideo::OpenStream - Creating codec: 27
2020-02-28 06:22:55.328 T:3911971712 NOTICE: Creating video thread
2020-02-28 06:22:55.328 T:3637498752 NOTICE: running thread: video_thread
2020-02-28 06:22:55.329 T:3911971712 NOTICE: Opening stream: 1 source: 256
2020-02-28 06:22:55.329 T:3911971712 NOTICE: Finding audio codec for: 86018
2020-02-28 06:22:55.329 T:3911971712 NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder aac
2020-02-28 06:22:55.329 T:3911971712 NOTICE: Creating audio thread
2020-02-28 06:22:55.330 T:3629106048 NOTICE: running thread: CVideoPlayerAudio::Process()
2020-02-28 06:22:55.340 T:3629106048 NOTICE: Creating audio stream (codec id: 86018, channels: 2, sample rate: 44100, no pass-through)
2020-02-28 06:22:55.448 T:4066762768 NOTICE: Whitelist search for: width: 1280, height: 720, fps: 23.976, 3D: false
2020-02-28 06:22:55.449 T:4066762768 NOTICE: Display resolution ADJUST : 3840x2160 @ 23.98 - Full Screen (37) (weight: 0.024)
2020-02-28 06:22:55.449 T:4066762768 NOTICE: VideoPlayer: OnLostDisplay received
2020-02-28 06:22:55.993 T:4066762768 NOTICE: VideoPlayer: OnResetDisplay received
2020-02-28 06:28:14.992 T:3637498752 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
2020-02-28 06:37:52.598 T:3911971712 WARNING: Previous line repeats 877 times.
2020-02-28 06:37:52.598 T:3911971712 NOTICE: CVideoPlayer::OnExit()
2020-02-28 06:37:52.598 T:3911971712 NOTICE: VideoPlayer: eof, waiting for queues to empty
2020-02-28 06:37:52.598 T:3911971712 NOTICE: Closing stream player 1
2020-02-28 06:37:52.598 T:3911971712 NOTICE: CDVDMessageQueue(audio)::WaitUntilEmpty
2020-02-28 06:37:52.598 T:3911971712 NOTICE: Waiting for audio thread to exit
2020-02-28 06:37:52.598 T:3629106048 NOTICE: thread end: CVideoPlayerAudio::OnExit()
2020-02-28 06:37:52.599 T:3911971712 NOTICE: Closing audio device
2020-02-28 06:37:52.930 T:3911971712 NOTICE: Deleting audio codec
2020-02-28 06:37:52.930 T:3911971712 NOTICE: Closing stream player 2
2020-02-28 06:37:52.930 T:3911971712 NOTICE: CDVDMessageQueue(video)::WaitUntilEmpty
2020-02-28 06:37:53.617 T:3911971712 NOTICE: waiting for video thread to exit
2020-02-28 06:37:53.617 T:3637498752 ERROR: Got MSGQ_ABORT or MSGO_IS_ERROR return true
2020-02-28 06:37:53.617 T:3637498752 NOTICE: thread end: video_thread
2020-02-28 06:37:53.617 T:3911971712 NOTICE: deleting video codec
2020-02-28 06:37:53.685 T:4066762768 NOTICE: CVideoPlayer::CloseFile()
2020-02-28 06:37:53.685 T:4066762768 NOTICE: VideoPlayer: waiting for threads to exit
2020-02-28 06:37:53.685 T:4066762768 NOTICE: VideoPlayer: finished waiting
2020-02-28 06:37:53.685 T:4066762768 NOTICE: CVideoPlayer::CloseFile()
2020-02-28 06:37:53.685 T:4066762768 NOTICE: VideoPlayer: waiting for threads to exit
2020-02-28 06:37:53.685 T:4066762768 NOTICE: VideoPlayer: finished waiting

Update:
The NAS and the network can be eliminated as a possible cause of the problem,
since the dropouts also occur, when playing the videos from a local attached USB disk.

Also I experimented with reproducing the problem.
I tried at least 20 videos. ALL of them have audio-dropouts at 4:03, 8:05, 12:06,…
And also all of them play just fine on any other devcie. (Tried my TV and two laptops with different player software).
When a dropout occurs - let’s say at 8:00 minutes, and I use the ‘skip backwards’ function and jump to 7:55, the audio then plays fine. But the problem re-appears at 12:00 minutes.
Also when I skip back a little more, to 6:30 for example the audio will drop out again exactly at 8:03 minutes.
So what happens in coreelec every 4 minutes of playtime?
Did no one else notice this? Just me?
Any ideas what I could try?
I also have a Odroid C2 lying around as well as some Raspberries. Maybe I’ll try these - just for kicks.

Lothar

Can you try nightlies.
See if it persists.
Use an SD Card external with Nightly if you’re wanting just to test.

I watch .mp4 files every day without any dropouts.
Videos are all stored on my NAS

kostaman, you hit the spot!
Installed last night nightly and it works very fine.
Watched 3 videos by now and not a single audio dropout.

Thank you!

Lothar