Auto update breaks boot ODROID-N2 SPI + USB HDD

I thought my hard drive was crashing. One day everything worked fine, the next it would not boot. However after lots of expense and frustration, I finally tracked it down to the auto update of coreelec. A new non booting kernel is getting forced onto me and I really don’t like it. At this point the only way I have of getting my system working again is as follows:

  1. start fresh with CoreELEC-Amlogic-ng.arm-9.2.3-Odroid_N2.img.gz on my ‘wd blue’ 250gb ssd (external usb).

  2. boot with ethernet UNPLUGGED.

  3. change the coreelect update settings to manual.

  4. change the coreelect settings to not notify for updates. THIS DOES NOT WORK.

Now I can reboot, and as long as I don’t accidentally click to the pester questions from 4) above that never goes away, then my system will work fine. If I click then my system will become un-bootable. It hangs in the SPI boot ‘looking for new usb device’.

So in total we have:

  1. new coreelec update breaks spi boot on external usb. I have tried 250gb WD blue and 180GB Intel Pro 1500 both same.

  2. notification message disable for updates does not work.

  3. IMHO the default for auto update should be set to manual at least for the first boot.

I think what you have built here folks is awesome but I really hate having stuff forced on me especially something rendering my system unbootable.

  1. Search the forums:
    Manually selecting the correct dtb on ODROID-N2 or ODROID-N2Plus
  2. The update and notify settings are fully respected since 9.2.4
  3. No

Updates were never forced on stable releases.
Only the notification system was having a bug, why it wasn’t possible to switch it off.

Update petitboot, and the 9.2.4.2 release should work.

There was a change related to supporting the N2Plus in CoreELEC that causes an issue with booting with older versions of petitboot on both N2 and N2Plus. However this has been fixed in newer versions of petitboot.

Once you bork your petitboot you have to reinstall it with a special sD card, which is frankly a pain in the arse if you don’t happen to have a spare sD card lying around.
The update broke my petitboot about a month ago and I still haven’t bothered to fix it because i have no spare sD and I aint going out to get one just for this. Its not difficult to repair but shouldn’t have to.

Shoog

Petitboot does not need uSD card to update (any more). It can be updated from the console with the command “pb-update”.

This doesn’t work once it is already trashed.

Shoog

No special SD Card required.

https://forum.odroid.com/viewtopic.php?t=37424

You do however need to be running your CE from an SD card which in my case amounts to exactly the same thing.

Shoog

About | FAQ | Terms of Service | Privacy Policy | Legal Notice