AV Port Reset Does Nothing!


I have an MX Pro+ 4k box which has a S905x and 2gb ram.

My issue is that the reset button in the av port doesn’t do anything. I press to click and hold and it didn’t help when installing coreelec so I used the terminal within android to ‘restart update’ which triggered the install from the sd card.

Now the big issue is that I can’t get into the recovery for the box as I wanted to make a backup.

I can get there through the terminal on android using ‘reboot recovery’ but that’s no good if the box gets bricked. I have read you need to hold the reset button down for 15 seconds when powering on and recovery should boot but my box just boots like normal.

I’m wondering if the box is faulty. Also wondering if on coreelec or android is pressing the reset button is supposed to reset the box? Mine does nothing.


So, you press the button in, you hear the click, & you hold it in, then you plug the power cable in, only releasing the button, when you see it start to boot?

Yes I hear the click. I’ve tried releasing when I see the boot logo after a few seconds, I’ve also tried holding it the whole time but it just boots to either coreelec or android if the ad is removed.

Doesn’t look like it’s working I guess which means I can’t install atvxperience or other roms :frowning: wouldn’t want to brick and box and not be able to get back into recovery.

I could install them by getting to recovery through the android terminal app but that’s useless if the box gets bricked.

Just opened the box and there is a button at the end of the av port but once again when clicked nothing happens. Guess I’ll just have to make do with the stock android experience :frowning:

At least coreelec works!

If you can’t send the box back, you could open the box to see if the reset button, does actually work.

Assuming you will do as recommended & install Libre/Core to sd/usb only & do not install to internal.

Then you can create tar backups on Libre/Core

As for changing ROM’s, IF, your device gets bricked, you might be able to use the burning tool? Never used it myself, I used the cardmaker.

Just opened the box and there is a reset button at the end of the av port but once again when clicked nothing happens.

I think even with the burning tool you need to press the reset button to access recovery, well from what I can tell. There are no physical buttons on the box either so no other way to access recovery I don’t think.

Guess I’ll just have to make do with the stock android experience :frowning:

At least coreelec works!

I meant open the box & test the switch with a multimeter to check continuity.

looks like other people have the same problem, https://forum.freaktab.com/forum/tv-player-support/amlogic-based-tv-players/s905/eny-acemax-ott-ac/589319-ott-mxq-pro-4k-recovery-mode-reset-button

there is another link that suggests that the card maker might work without reset.

I think @bubblegum57 is pointing out that, sometimes, these buttons are fitted but not actually soldered (and therefore possibly fixable).
I have personally experienced this with other 'el cheapo boxes :slightly_smiling_face:

I have the same box and had the same problem. I got it fixed by installing the oldest firmware version I could find. After that the toothpick method works for me.
You can find the firmware here : http://blog.geekbuying.com/2017/11/mxq-pro-android-7-1-2-amlogic-s905x-2gb16gb-tv-box-firmware-update-20171121/

Just install using the am logic burn tool. Then reinstall coreelec. That’s how I got it working.

Hey, thanks so much. I’ll give it a go!