AVL6862 using DVB-C and TVHeadend

Hey, I have a Mecool K3 Pro with an integrated AVL6862 DVB-C tuner and I have not had much luck in the past getting it to work decently. I just did a fresh install of CE 9.0.0 and thought I give it another shot but I’m still struggling with it.

I installed TVHeadend 4.2.7-44 ~ CoreELEC Tvh-addon v9.0.118 and I’ve tried both CrazyCat and the drivers from the latest kernel (media_build). Both of them detect the card but as soon as I try to scan 2 manually defined muxes I get this error with both of the drivers.

2019-02-22 22:58:50.942 mpegts: 146MHz in DNA - tuning on Availink avl6862 #0 : DVB-C #0
2019-02-22 22:58:50.943 linuxdvb: Availink avl6862 #0 : DVB-C #0 - failed to tune [e=Invalid argument]

I know the mux definition is correct because I can link the same network with those muxes to my other USB based DVB-C tuner, move over the antenna cable and it finds all the 33 muxes that it’s supposed to.

To my surprise, I noticed running TVHeadend on my Mecool using docker image, the tuner seems to work both with CrazyCat and with latest kernel (media_build) drivers. It only finds roughly 29 of the 33 muxes but I guess that’s better than nothing and I’ve seen multiple other people having similar issues so I guess it’s expected.

I would appreciate if anybody has some suggestion in case there is something I can try to fix it. Or if somebody would have time to look into the issue. I would also be interested to hear if op has had success with this box using specifically the dvb-c tuner?

I took one dmesg output straight after booting the box up and going into tvheadend and trying to scan the muxes. http://ix.io/1BMP

I also tried to enable debugging options (debug and trace options for subsytem linuxdvb) but for whatever reason it just logs some info notices about epgdb into the log file.



Update: The error message above seems not to be related to the problem I had as I get that in the docker container also.

The mux auto-discovery seems to have found the missing muxes. Still some of them are empty and it’s missing roughly 20 / 155 services but I’m glad it’s not more.

I also noticed that my USB based tuner seems to take heavy interference from the built-in tuner. Moving them away 50cm did wonders. I started getting some continuity errors / tuning issues on the USB tuner when they were close.

Due to some added benefits I’m gonna stay with the docker container solution.

Feel free to close the topic.

Hey, I’m having exactly the same problem with my Magicsee C400 Plus (I believe they are twins with KIII Pro). Did you succeed at solving this? I can’t tune to any DVB-C channel, always get this ‘failed to tune’ in debug log and no channels in TVHeadend. Tried various mux parameters, all to no result. Any help would be appreciated.

Unfortunately I can’t remember exactly what fixed it but I did a reinstall from scratch on 9.0.2 and no special configuration was required. I actually don’t use the built-in tuner at the moment but I have used it after I did the reinstallation.

I’m using “DVB drivers from the latest kernel” and I run TVH from Docker image but I did try the CE version of TVH a few weeks ago and it worked.

I hope you get your issue solved.

Thanks! I found a solution. It turned out that I just had to specify the correct symbol rate in mux settings. For me it was 6956000.