Backup fails

I just did a cleaninstall with CoreElec 20.1. Finally I tried to make an automatic backup, but the backup always fails. Near the end of the backup, the box hangs up and I have to unplug it to reboot. Sometimes it also automatically reboots.

I installed Coreelec twice on different SDcards. I have tried to backup all “.” foldersover SSH (WinSCP). This works except one file. I cannot copy “/storage/.kodi/temp/commoncache.socket”. Do I need this file for my backup?
Can I use this copy to restore my box or do I have to do anything else for a full backup?

box: S905x with gxl_p212_2g

Most probably the box has old bootloader.
If the Android on the box 6.x, then it is a known issue, Please upgrade the Android on the device to 7.x and it will work correctly

Try this, I use something similar for years without problems. In my version, the backups are also transferred to my server, also executing a deletion of the oldest backups:

# script
cd /storage/backup/ && tar -cvf $(date +%Y%m%d%H%M%S).tar \
  --exclude=Thumbnails --exclude=.thumbnails --exclude=temp \
  /storage/.kodi /storage/.cache /storage/.config /storage/.opt /storage/.ssh

The secret of this script is in ‘cd /storage/backup/’

Yes, Android is 6.x. Could I copy Coreelec to internal memory instread of upgrading to Android7? Would that also upgrade the bootloader? Upgrading AND copying to internal would doubl the chance to brick my box. I dont need Android anymore on that box. To minmum the risk I would perfer to update the bootloader while copying to internal. Is that passible?

@cubimol thank you! I will try your script!

No, you have to upgrade to Android 7.x to get the new bootloader. That is a basic requirement for CE as per the wiki

CoreELEC is a Just enough OS Linux distribution, combining cutting edge hardware support with a small disk and memory footprint while providing an efficient, elegant and non-destructive solution to deliver a complete Kodi Entertainment Center experience for Android-based set-top boxes using the ARMv8.x-A platform with Android 7.1 or greater pre-installed.

Once you do that then you can put CoreElec on the emmc. bootloader is not part of CoreElec.

Thank you for your help!
I have updated to Android 7 and now everything including backups works perfect!

It took my a lot of time to find a usable firmware. Finally I found a link in this forum!
If anybody else needs an update for an EgoIggo S95Xpro (2g/16g) box, you can use the img file: “HQYG-TX7-nikodi-20180104”

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.