Beelink GT-King fails to boot CE ("footer is wrong")

I installed LE/CE etc. on many S905 boxes before using the exact same method (just last week I did another one), so now I bought a Beelink GT-King, but I am unable to boot CE:

*) used rufus to put CoreELEC-Amlogic-ng.arm-9.2.5-Generic.img on USB Stick I used for my S905 boxes, but later also on an MicroSD (makes no difference) and using the included MicroSD which seems to have some version of CoreELEC on it - so I tried 3 different media multiple times
*) copied g12b_s922x_beelink_gt_king.dtb to dtb.img in root dir of stick/uSD
*) created empty (also tried an which contains some dummy txt file)
*) safely ejected stick/uSD
*) local update in android, select zip, reboot
*) recovery bootloader comes up
*) “E: footer is wrong”, “E: Signature verification failed”, “E: error: 21”, “Installation aborted”

I also updated the Android Firmware, doesn’t make any difference (as expected).

What’s my mistake? I’ve done this many times and I believe if the dtb was wrong, it would go beyond the above but then be blank, so that shouldn’t be the issue.
I found a few topics with the same error, but all the mistakes/solutions I found did not apply for me/work. The only difference I noticed is, that in other people’s screenshots it writes out the name of the update package in the “opening update package…” line (like “usb/” or similar)

Please help!


Try the alternative method:

  • delete from flash card
  • start android
  • download app ‘Reboot to LibreELEC’
  • find a way to root android
  • run ‘Reboot to LibreELEC’

The GT-King has a reset button in the PL3.5 port, press it and plug the power in.

thanks so much guys!
“Reboot to LibreELEC” apk worked perfectly and after that flawless install to eMMC and restore from S905 config!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.