Beelink GT King Wifi voice remote not working with 19 & 20

Hello, recent Kodi addon updates required Matrix or better and automatic updates weren’t going past 18 on Coreelec. So I did the manual updates and have been trying 19 & 20 which work perfectly except the 2.4Ghz wifi remote that comes stock with GT King (6B9X). Worked with 18. I’ve looked through the wiki and topics but they are all IR controllers.
How do I go about finding instructions to fix this?
The remote looks like a G10 but model says: Ari W
Air mouse & voice

This remote has USB dongle and should just work out of the box?

No dongle. Worked without it. Still works when I boot to eMMC regular android and earlier version of Coreelec. So I guess I need to somewhere add a config file or something.

And it is wifi remote so maybe goes through webserver and oh my goodness it took me a while to find the Control> allow remote control via HTTP which is hidden in Coreelec and LibreElec

Interface> Skin> Configure skin…> General> Show weather info in top bar with a slider but when clicked on it opens the Settings/Services that now includes Control
Freaking weird! Not included like previously under System or Coreelec settings.

But it requires a password to be in place to enable so can’t input that with the remote.
But now perhaps Kore app will work.

Update: was able to not use a password and Kore and Yatse work but not remote.
Be careful in those Control settings as somehow I disabled wifi altogether, couldn’t get it back and had to restore backup to get things working again. Then I just switched on “Allow remote control via HTTP” and under Application control “Allow remote control from applications on this system” and “Allow remote control from applications on other systems” (lots of warnings that now my system isn’t protected but it’s just my Kodi box and I keep the naked pictures of my cat elsewhere).

Please download this remote file and drop it in .config directory.

thanks, will give it a go and report back

You’ve fixed the problem?? I’m in the same situation as you, and I don’t know how to fix it… I have the remote via bluetooth and it “works”, but it doesn’t the other way. I would appreciate your help if you solve it, thanks!


I finally got it! I was able to solve the problem, which was the same as yours! Do as they say above, paste the “remote.config” file to the root of the card BEFORE INSTALLING COREELEC. Just when you create the image on the sd and modify the “dtb.img” file, add the “remote.config” of your remote and when installing it WORKS!


@hebekiah @Chulejake Did you manage to solve it? I used the remote.conf file and it worked but only the first time… Also, can you actually power up the device with the remote? I can when it powers off from the Android system but I can’t power up the device when it powers off from CoreELEC. And what about the mouse option, does it work?

Thanks in advance!

EDIT: Finally solved it, it turns out the remote pairs using bluetooth. How silly I missed that!

My remote control works perfectly without connecting via bluetooth… I just did what I said: I mounted the Coreelec image on the sd, changed the dtb.img file and inserted the remote.config file… Then I installed Coreelec and everything it worked the first time… Coreelec Nexus…


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.