Beelink GT1: boot time 1min longer if not connected to monitor

Dear CoreElec community,

** Solved **
** I use a ‘HDMI dummy/ Edid emulator’ **

I have updated CoreElec on my Beelink GT1 from 9.2.2 to 9.2.5.
From the device trees, I use gxm_q200_2g.dtb

Since then, the boot time seems to depend on what is connected to the HDMI port.
Here is an overview:
-nothing connected → boot time = 1.23 minutes
-only a hdmi cable is connected → boot time = 1.23
-hdmi cable+ monitor is connected → boot time = 0.23 minutes
-hdmi cable + HDMI to VGA adapter + no monitor–> boot time = 0.23 minutes

I use the Kore app on my smartphone as a ‘remote control’.
The internet connection (wifi or Lan) makes no diference in the boot-times.

I use the Beelink just to play audio via the optical out,
so normally there’s no need to have the hdmi cable connected.

What could cause this 1 minute delay in boot time?
Is it Linux or something with Kodi?

Thank you for your help!
Tycho (The Netherlands)

Kodi is waiting for a monitor as the user defined resolution is set on start.
If no monitor is connected Kodi does not know what resolution should be used as no EDID information is available. After a timeout 720p is set as default.
You can run systemctl disable kodi and kodi is not starting at all on next boot up.

1 Like

If Linux has a nice precise delay time on bootup - that generally means it is doing its job and waiting for a set time for a specific event. Since Kodi is primarily a media player it will always test for a output device (monitor) and wait for it to be present for a set amount of time.
This is a useful fault finding piece of info since delayed starts can be traced to the specific event which triggers the delay and will be shown in the console boot sequence as a wait event.


Thank you Portisch for your reply.
Actually, I was thinking in the same direction.

But the strange thing is:
-with coreelec version 9.2.2. this issue was not there
-when the hdmi-vga adapter is connected to the hmdi cable, without a monitor, the 1min delay is also skipped. Is the adaptor is passive, I suppose, meaning, it doesn’t give information.

I just keep the adaptor connected, it’s a simple solution. But my ‘scientific mind’ is not so happy with this solution :slight_smile:

Thank you, Shoog, for information and tip.
Maybe I can find something in a log file.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.