Beelink GT1 Ultimate LPN1 - not able to boot from SD card


#1

Any help will be appriciated as I’m starting to get nuts…

HW (checked in Android using Device Info app):
SOC: S912
Model: Beelink Gt1 Ultimate
Storage: 32GB
Ram: 3GB
DTB: gxm_q201_3g
S/N: LPN1GBNG9xxxx

SW:
Android 7.1.2

I was able to boot into TWRP ver. 3.1.1. from the SD card which means that I now have a backup of the pre-installed android system.

My problem is that I’m not able to boot into CoreElec from the SD Card. The device boots, but is get stuck in the Beelink Logo no matter which image I use. I downloaded the image for the Mecool pro L as I noticed this once for dtb ‘gxm_q201_3g’. I have also tried to download the generic image which also just get stuck during boot in the Beelink logo.

Even though I was pretty sure that it would not work I also tried the two images available for the Beelink GT1 Ultimate…same result, stuck in the Beelink logo.

Any suggestions?


#2

Use gxm_q200_3g
image
|
image
|
image
|


#3

@boot2k3 - Many thanks for your quick reply.

I have already tried to use the image with the dtb gxm_q200_3g.dtb earlier and it didn’t work. I did however get it to work after I replaced the dtb with gxm_q201_3g_1gbit.dtb.